From: Chaitanya Kulkarni <chaitanyak@nvidia.com>
To: Damien Le Moal <damien.lemoal@opensource.wdc.com>,
"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Cc: "axboe@kernel.dk" <axboe@kernel.dk>,
"johannes.thumshirn@wdc.com" <johannes.thumshirn@wdc.com>,
"bvanassche@acm.org" <bvanassche@acm.org>,
"ming.lei@redhat.com" <ming.lei@redhat.com>,
"shinichiro.kawasaki@wdc.com" <shinichiro.kawasaki@wdc.com>,
"vincent.fu@samsung.com" <vincent.fu@samsung.com>,
"yukuai3@huawei.com" <yukuai3@huawei.com>
Subject: Re: [PATCH 1/6] null_blk: allow write zeores on non-membacked
Date: Wed, 5 Oct 2022 18:33:38 +0000 [thread overview]
Message-ID: <41075ae7-6e01-540f-6a68-eac2b9390093@nvidia.com> (raw)
In-Reply-To: <2553fcde-43b0-04c0-5f62-9a2c1f9430a1@nvidia.com>
>>> +static bool g_write_zeroes;
>>> +module_param_named(write_zeroes, g_write_zeroes, bool, 0444);
>>> +MODULE_PARM_DESC(write_zeroes, "Support write-zeores operations. Default: false");
>>
>> Why not make this a number of sectors representing the maximum size of a
>> write zero command (blk_queue_max_write_zeroes_sectors()) ? That would
>> allow exercising split write zeros BIOs.
>>
>
> I kept the implementation identical to the g_discard.
>
> Perhaps it's time to change it so REQ_OP_DISCARD and
> REQ_OP_WRITE_ZEROES will have same implementation.
>
> I'll add a discard patch to match your suggested write-zeroes
> behavior.
>
> -ck
>
REQ_OP_DISCARD and REQ_OP_WRITE_ZEORES needs to be consistent
when it comes to configuration interface.
I did the change you suggested, it is breaking the backward
compatibility of discard and if we do it only for write-zeroes it
will be inconsistent with the current g_discard behavior.
Let's keep the original behavior and not break the backward
compatibility ?
-ck
next prev parent reply other threads:[~2022-10-05 18:33 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-10-05 3:16 [PATCH 0/6] null_blk: allow REQ_OP_WRITE_ZEROES and cleanup Chaitanya Kulkarni
2022-10-05 3:16 ` [PATCH 1/6] null_blk: allow write zeores on non-membacked Chaitanya Kulkarni
2022-10-05 4:54 ` Damien Le Moal
2022-10-05 5:24 ` Chaitanya Kulkarni
2022-10-05 18:33 ` Chaitanya Kulkarni [this message]
2022-10-05 3:16 ` [PATCH 2/6] null_blk: allow write zeores on membacked Chaitanya Kulkarni
2022-10-05 4:57 ` Damien Le Moal
2022-10-05 5:10 ` Chaitanya Kulkarni
2022-10-05 17:18 ` Brian Foster
2022-10-05 3:16 ` [PATCH 3/6] null_blk: code cleaup Chaitanya Kulkarni
2022-10-05 5:02 ` Damien Le Moal
2022-10-05 5:21 ` Chaitanya Kulkarni
2022-10-05 3:16 ` [PATCH 4/6] null_blk: initialize cmd->bio in __alloc_cmd() Chaitanya Kulkarni
2022-10-05 5:04 ` Damien Le Moal
2022-10-05 3:17 ` [PATCH 5/6] null_blk: don't use magic numbers in the code Chaitanya Kulkarni
2022-10-05 5:05 ` Damien Le Moal
2022-10-05 3:17 ` [PATCH 6/6] null_blk: remove extra space in switch condition Chaitanya Kulkarni
2022-10-05 5:06 ` Damien Le Moal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=41075ae7-6e01-540f-6a68-eac2b9390093@nvidia.com \
--to=chaitanyak@nvidia.com \
--cc=axboe@kernel.dk \
--cc=bvanassche@acm.org \
--cc=damien.lemoal@opensource.wdc.com \
--cc=johannes.thumshirn@wdc.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ming.lei@redhat.com \
--cc=shinichiro.kawasaki@wdc.com \
--cc=vincent.fu@samsung.com \
--cc=yukuai3@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®