From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752187AbdAYLZQ (ORCPT ); Wed, 25 Jan 2017 06:25:16 -0500 Received: from mail-yb0-f173.google.com ([209.85.213.173]:33103 "EHLO mail-yb0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751994AbdAYLZM (ORCPT ); Wed, 25 Jan 2017 06:25:12 -0500 Subject: Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA To: Mark Rutland References: <1484789346-21012-1-git-send-email-labbott@redhat.com> <1484789346-21012-2-git-send-email-labbott@redhat.com> <20170119105646.GA11176@leverpostej> Cc: Kees Cook , Jason Wessel , Jonathan Corbet , Russell King , Catalin Marinas , Will Deacon , "James E.J. Bottomley" , Helge Deller , Martin Schwidefsky , Heiko Carstens , Thomas Gleixner , Ingo Molnar , "H. Peter Anvin" , x86@kernel.org, Rob Herring , "Rafael J. Wysocki" , Len Brown , Pavel Machek , Jessica Yu , linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-parisc@vger.kernel.org, linux-s390@vger.kernel.org, linux-pm@vger.kernel.org, kernel-hardening@lists.openwall.com From: Laura Abbott Message-ID: <4116b91a-4fb5-414d-5fd5-36be151c600c@redhat.com> Date: Wed, 25 Jan 2017 12:25:03 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.6.0 MIME-Version: 1.0 In-Reply-To: <20170119105646.GA11176@leverpostej> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/19/2017 11:56 AM, Mark Rutland wrote: > Hi Laura, > > On Wed, Jan 18, 2017 at 05:29:05PM -0800, Laura Abbott wrote: >> >> Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option >> provides key security features that are to be expected on a modern >> system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more >> accurately describes what this option is intended to do. > > This generally sounds good. Thanks for attacking this! > > On the bikeshedding front, *maybe* it would be nice to mention > permissions in the name, something like STRICT_KERNEL_RWX. That might > also prevent the reading of 'hardened' as 'optional overhead'. > > That said, the proposed name is fine by me -- I'm happy so long as > 'DEBUG' goes. > (Apologies for the delay, my SMTP was set up incorrectly so my messages didn't actually get sent out) I like that better since it's describing specifically what the config should be setting as opposed to something more vague. That might fit better with what Pavel was suggesting as well. Thanks, Laura