From: "Devin Heitmueller" <devin.heitmueller@gmail.com>
To: "Harvey Harrison" <harvey.harrison@gmail.com>
Cc: "Michael Krufky" <mkrufky@linuxtv.org>,
"Mauro Carvalho Chehab" <mchehab@infradead.org>,
v4l-maintainer <v4l-dvb-maintainer@linuxtv.org>,
"Andrew Morton" <akpm@linux-foundation.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [v4l-dvb-maintainer] [PATCH] dvb: usb vendor_ids/product_ids are __le16
Date: Fri, 14 Nov 2008 14:25:57 -0500 [thread overview]
Message-ID: <412bdbff0811141125x34de747dm85b47f61b604219a@mail.gmail.com> (raw)
In-Reply-To: <1226690438.5483.39.camel@brick>
On Fri, Nov 14, 2008 at 2:20 PM, Harvey Harrison
<harvey.harrison@gmail.com> wrote:
> On Fri, 2008-11-14 at 14:15 -0500, Michael Krufky wrote:
>> On Fri, Nov 14, 2008 at 2:07 PM, Harvey Harrison
>> <harvey.harrison@gmail.com> wrote:
>> > On Fri, 2008-11-14 at 14:05 -0500, Michael Krufky wrote:
>> >> Wouldn't it be nicer to just switch on
>> >> cpu_to_le16(udev->descriptor.idVendor) ? This would be a 1-line change,
>> >> compile to a smaller footprint, and be easier to read.
>> >>
>> >> Personally, I prefer to try to avoid duplicating code in places where a
>> >> single operation may occur centrally.
>> >
>> > On a little-endian arch it makes no difference obviously, but on a
>> > big-endian arch it's the difference between compile-time and runtime
>> > byteswapping.
>> >
>>
>> Its not my driver, but I think that doing the operation on the switch
>> is prettier than doing it on each case statement. Also, it would
>> avoid future bugs, if somebody decides to add new cases to the switch
>> block.
>
> The alternative is to define the vendor ids as little-endian in the headers
> then you don't need the endian swap in the switch or the case, but that would
> require looking at the other uses first....or gently encourage more people to run sparse ;-)
>
> Harvey
Harvey,
If I may offer my opinion, this is not remotely performance-critical
code. That said, I would favor on the side of
maintainability/reliability in this case, and mkrufky's approach seems
to be better on both accounts.
Regards,
Devin
--
Devin J. Heitmueller
http://www.devinheitmueller.com
AIM: devinheitmueller
next prev parent reply other threads:[~2008-11-14 19:26 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-11-14 18:19 Harvey Harrison
2008-11-14 19:05 ` [v4l-dvb-maintainer] " Michael Krufky
2008-11-14 19:07 ` Harvey Harrison
2008-11-14 19:15 ` Michael Krufky
2008-11-14 19:20 ` Harvey Harrison
2008-11-14 19:25 ` Devin Heitmueller [this message]
2008-11-14 19:44 ` Harvey Harrison
2008-11-14 20:55 ` Andy Walls
2008-11-14 21:08 ` Harvey Harrison
2008-11-15 10:42 ` Hans Verkuil
2008-11-15 7:21 ` Jean-Francois Moine
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=412bdbff0811141125x34de747dm85b47f61b604219a@mail.gmail.com \
--to=devin.heitmueller@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=harvey.harrison@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mchehab@infradead.org \
--cc=mkrufky@linuxtv.org \
--cc=v4l-dvb-maintainer@linuxtv.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome