From: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
To: Konrad Dybcio <konrad.dybcio@linaro.org>,
Luca Weiss <luca@z3ntu.xyz>,
~postmarketos/upstreaming@lists.sr.ht,
phone-devel@vger.kernel.org, Rob Clark <robdclark@gmail.com>,
Abhinav Kumar <quic_abhinavk@quicinc.com>,
Sean Paul <sean@poorly.run>, David Airlie <airlied@gmail.com>,
Daniel Vetter <daniel@ffwll.ch>, Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Conor Dooley <conor+dt@kernel.org>,
Krishna Manikandan <quic_mkrishn@quicinc.com>,
Andy Gross <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>
Cc: linux-arm-msm@vger.kernel.org, dri-devel@lists.freedesktop.org,
freedreno@lists.freedesktop.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/7] drm/msm/mdp5: Add MDP5 configuration for MSM8226
Date: Mon, 29 May 2023 16:34:07 +0300 [thread overview]
Message-ID: <419972e3-3052-87ae-a471-5fcf0a01f7da@linaro.org> (raw)
In-Reply-To: <9858de8d-54ae-aa0c-35d8-fe8c1c8473b7@linaro.org>
On 29/05/2023 14:59, Konrad Dybcio wrote:
>
>
> On 29.05.2023 11:44, Luca Weiss wrote:
>> Add the required config for the v1.1 MDP5 found on MSM8226.
>>
>> Signed-off-by: Luca Weiss <luca@z3ntu.xyz>
>> ---
>> drivers/gpu/drm/msm/disp/mdp5/mdp5_cfg.c | 82 ++++++++++++++++++++++++++++++++
>> 1 file changed, 82 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/msm/disp/mdp5/mdp5_cfg.c b/drivers/gpu/drm/msm/disp/mdp5/mdp5_cfg.c
>> index 2eec2d78f32a..694d54341337 100644
>> --- a/drivers/gpu/drm/msm/disp/mdp5/mdp5_cfg.c
>> +++ b/drivers/gpu/drm/msm/disp/mdp5/mdp5_cfg.c
>> @@ -103,6 +103,87 @@ static const struct mdp5_cfg_hw msm8x74v1_config = {
>> .max_clk = 200000000,
>> };
>>
>> +static const struct mdp5_cfg_hw msm8x26_config = {
> Luca, this patch looks good as-is (without diving into the values).
>
> Dmitry, I see some things that we may improve here..
>
> 1. Rename msm8xab to msm89ab or something, it's really inconsistent
> with other drivers
>
> 2. Some values seem very common / always constant.. perhaps we could
> add some #defines like we do in DPU?
I really would not like to go the DPU way here. Maybe we can define the
'full-featured' masks, while leaving the older hardware intact.
> 3. Can we add some magic defines to make flush_hw_mask non-cryptic?
Sounds like a good idea, especially since we have all the defines. I'll
tend to it after landing 8226.
>
> 4. We can probably use pointers in data structs and deduplicate identical
> blocks!
Let's see.
>
> Konrad
>> + .name = "msm8x26",
>> + .mdp = {
>> + .count = 1,
>> + .caps = MDP_CAP_SMP |
>> + 0,
>> + },
>> + .smp = {
>> + .mmb_count = 7,
>> + .mmb_size = 4096,
>> + .clients = {
>> + [SSPP_VIG0] = 1,
>> + [SSPP_DMA0] = 4,
>> + [SSPP_RGB0] = 7,
>> + },
>> + },
>> + .ctl = {
>> + .count = 2,
>> + .base = { 0x00500, 0x00600 },
>> + .flush_hw_mask = 0x0003ffff,
>> + },
>> + .pipe_vig = {
>> + .count = 1,
>> + .base = { 0x01100 },
>> + .caps = MDP_PIPE_CAP_HFLIP |
>> + MDP_PIPE_CAP_VFLIP |
>> + MDP_PIPE_CAP_SCALE |
>> + MDP_PIPE_CAP_CSC |
>> + 0,
>> + },
>> + .pipe_rgb = {
>> + .count = 1,
>> + .base = { 0x01d00 },
>> + .caps = MDP_PIPE_CAP_HFLIP |
>> + MDP_PIPE_CAP_VFLIP |
>> + MDP_PIPE_CAP_SCALE |
>> + 0,
>> + },
>> + .pipe_dma = {
>> + .count = 1,
>> + .base = { 0x02900 },
>> + .caps = MDP_PIPE_CAP_HFLIP |
>> + MDP_PIPE_CAP_VFLIP |
>> + 0,
>> + },
>> + .lm = {
>> + .count = 2,
>> + .base = { 0x03100, 0x03d00 },
>> + .instances = {
>> + { .id = 0, .pp = 0, .dspp = 0,
>> + .caps = MDP_LM_CAP_DISPLAY, },
>> + { .id = 1, .pp = -1, .dspp = -1,
>> + .caps = MDP_LM_CAP_WB },
>> + },
>> + .nb_stages = 2,
>> + .max_width = 2048,
>> + .max_height = 0xFFFF,
>> + },
>> + .dspp = {
>> + .count = 1,
>> + .base = { 0x04500 },
>> + },
>> + .pp = {
>> + .count = 1,
>> + .base = { 0x21a00 },
>> + },
>> + .intf = {
>> + .base = { 0x00000, 0x21200 },
>> + .connect = {
>> + [0] = INTF_DISABLED,
>> + [1] = INTF_DSI,
>> + },
>> + },
>> + .perf = {
>> + .ab_inefficiency = 100,
>> + .ib_inefficiency = 200,
>> + .clk_inefficiency = 125
>> + },
>> + .max_clk = 200000000,
>> +};
>> +
>> static const struct mdp5_cfg_hw msm8x74v2_config = {
>> .name = "msm8x74",
>> .mdp = {
>> @@ -1236,6 +1317,7 @@ static const struct mdp5_cfg_hw sdm660_config = {
>>
>> static const struct mdp5_cfg_handler cfg_handlers_v1[] = {
>> { .revision = 0, .config = { .hw = &msm8x74v1_config } },
>> + { .revision = 1, .config = { .hw = &msm8x26_config } },
>> { .revision = 2, .config = { .hw = &msm8x74v2_config } },
>> { .revision = 3, .config = { .hw = &apq8084_config } },
>> { .revision = 6, .config = { .hw = &msm8x16_config } },
>>
--
With best wishes
Dmitry
next prev parent reply other threads:[~2023-05-29 13:34 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-29 9:43 [PATCH 0/7] Display support " Luca Weiss
2023-05-29 9:43 ` [PATCH 1/7] dt-bindings: msm: dsi-phy-28nm: Document msm8226 compatible Luca Weiss
2023-05-29 18:22 ` Conor Dooley
2023-05-29 9:43 ` [PATCH 2/7] dt-bindings: display/msm: dsi-controller-main: Add " Luca Weiss
2023-05-29 18:20 ` Conor Dooley
2023-05-29 9:44 ` [PATCH 3/7] dt-bindings: display/msm: qcom,mdp5: " Luca Weiss
2023-05-29 18:20 ` Conor Dooley
2023-05-29 9:44 ` [PATCH 4/7] drm/msm/mdp5: Add MDP5 configuration for MSM8226 Luca Weiss
2023-05-29 11:59 ` Konrad Dybcio
2023-05-29 13:34 ` Dmitry Baryshkov [this message]
2023-05-29 12:56 ` [Freedreno] " Dmitry Baryshkov
2023-05-29 9:44 ` [PATCH 5/7] drm/msm/dsi: Add " Luca Weiss
2023-05-29 12:08 ` Konrad Dybcio
2023-05-29 12:15 ` Dmitry Baryshkov
2023-05-29 9:44 ` [PATCH 6/7] drm/msm/dsi: Add phy " Luca Weiss
2023-05-29 10:25 ` Konrad Dybcio
2023-05-29 9:44 ` [PATCH 7/7] ARM: dts: qcom: msm8226: Add mdss nodes Luca Weiss
2023-05-29 12:10 ` Konrad Dybcio
2023-05-29 12:19 ` Dmitry Baryshkov
2023-05-29 12:22 ` Konrad Dybcio
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=419972e3-3052-87ae-a471-5fcf0a01f7da@linaro.org \
--to=dmitry.baryshkov@linaro.org \
--cc=agross@kernel.org \
--cc=airlied@gmail.com \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=daniel@ffwll.ch \
--cc=devicetree@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=freedreno@lists.freedesktop.org \
--cc=konrad.dybcio@linaro.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luca@z3ntu.xyz \
--cc=phone-devel@vger.kernel.org \
--cc=quic_abhinavk@quicinc.com \
--cc=quic_mkrishn@quicinc.com \
--cc=robdclark@gmail.com \
--cc=robh+dt@kernel.org \
--cc=sean@poorly.run \
--cc=~postmarketos/upstreaming@lists.sr.ht \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®