Werner Almesberger wrote: > Con Kolivas wrote: > >>While not being able to comment on the actual patch I think having a 1 >>or 0 for different types is not clear. > > > Yeah, it's not pretty. I also hope this division to be very > transitional, that's why I didn't bother to do anything nicer. > > >>Naming them different struct names would seem to me much more readable. > > > Struct names ? I'd rather not duplicate everything. Or did you mean > initialization function names, e.g. INIT_RAW_PRIO_TREE_ROOT ? > Or, for just the flag, maybe something like > #define PRIO_TREE_RAW 1 > #define PRIO_TREE_NORMAL 0 Initialisation function names. Cheers, Con