Linus Torvalds wrote: > > I really think you should update the "simple_xxx()" functions instead, and > thus make this happen for _any_ filesystem that uses the simple fs helper > functions. > Ok, I revised the patch. This is just the first step with changes to libfs and ramfs. To move the directory i_size handling completely to libfs it is necessary to allocate the inodes in libfs. Therefore, simple_get_inode() and simple_mknod_init() (honestly, I don't like that name) are introduced. simple_mknod_init() uses a callback mechanism to initialize the file system specific stuff of the inodes. What do you think of it? Jan