mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Damon Ding <damon.ding@rock-chips.com>
To: Luca Ceresoli <luca.ceresoli@bootlin.com>,
	hjc@rock-chips.com, heiko@sntech.de, andy.yan@rock-chips.com,
	maarten.lankhorst@linux.intel.com, mripard@kernel.org,
	tzimmermann@suse.de, airlied@gmail.com, simona@ffwll.ch,
	robh@kernel.org, krzk+dt@kernel.org, conor+dt@kernel.org,
	andrzej.hajda@intel.com, neil.armstrong@linaro.org,
	rfoss@kernel.org
Cc: Laurent.pinchart@ideasonboard.com, jonas@kwiboo.se,
	jernej.skrabec@gmail.com, nicolas.frattaroli@collabora.com,
	alchark@gmail.com, cristian.ciocaltea@collabora.com,
	sebastian.reichel@collabora.com, kever.yang@rock-chips.com,
	heiko.stuebner@cherry.de, tomeu@tomeuvizoso.net,
	amadeus@jmu.edu.cn, michael.riesch@collabora.com,
	didi.debian@cknow.org, dmitry.baryshkov@oss.qualcomm.com,
	dianders@chromium.org, m.szyprowski@samsung.com,
	dri-devel@lists.freedesktop.org, devicetree@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 7/9] drm/bridge: analogix_dp: Rename and simplify is_rockchip()
Date: Tue, 24 Mar 2026 14:12:31 +0800	[thread overview]
Message-ID: <42c0641f-2e37-4ca4-a1ae-e8fde24c8460@rock-chips.com> (raw)
In-Reply-To: <DHAANFJ6QZKU.5NN7RD47T8TI@bootlin.com>

Hi Luca,

On 3/24/2026 12:14 AM, Luca Ceresoli wrote:
> On Thu Mar 19, 2026 at 11:40 AM CET, Damon Ding wrote:
>> Rename is_rockchip() to analogix_dp_is_rockchip() for naming consistency
>> and readability, and simplify the code with switch.
>>
>> Signed-off-by: Damon Ding <damon.ding@rock-chips.com>
>> Suggested-by: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>
> 
> The patch content is OK:
> Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
> 
> However this won't apply without [0], correct?
> 
> So, worth mentioning in the cover letter that this series depends on the
> [0] series.
> 
> [0] https://lore.kernel.org/all/20260319071452.1961274-8-damon.ding@rock-chips.com/
> 

Yes, I will add it in v3.

Best regards,
Damon


  reply	other threads:[~2026-03-24  6:12 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-03-19 10:40 [PATCH v2 0/9] Add eDP support for RK3576 Damon Ding
2026-03-19 10:40 ` [PATCH v2 1/9] dt-bindings: display: rockchip: analogix-dp: Expand clock-names "hclk" for the third clock Damon Ding
2026-03-20  9:19   ` Krzysztof Kozlowski
2026-03-20  9:41     ` Krzysztof Kozlowski
2026-03-23 10:05       ` Damon Ding
2026-03-23  8:49     ` Damon Ding
2026-03-23  9:24       ` Krzysztof Kozlowski
2026-03-23  9:59         ` Damon Ding
2026-03-19 10:40 ` [PATCH v2 2/9] arm64: dts: rockchip: Add missing clock "hclk" for RK3588 eDP0 nodes Damon Ding
2026-03-19 10:40 ` [PATCH v2 3/9] arm64: dts: rockchip: Add missing clock "hclk" for RK3588 eDP1 nodes Damon Ding
2026-03-19 10:40 ` [PATCH v2 4/9] drm/rockchip: analogix_dp: Enable clock "hclk" for RK3588 Damon Ding
2026-03-19 10:40 ` [PATCH v2 5/9] dt-bindings: display: rockchip: analogix-dp: Add support for RK3576 Damon Ding
2026-03-19 10:40 ` [PATCH v2 6/9] arm64: dts: rockchip: Add eDP node " Damon Ding
2026-03-19 10:40 ` [PATCH v2 7/9] drm/bridge: analogix_dp: Rename and simplify is_rockchip() Damon Ding
2026-03-23 16:14   ` Luca Ceresoli
2026-03-24  6:12     ` Damon Ding [this message]
2026-03-25  3:58       ` Damon Ding
2026-03-19 10:40 ` [PATCH v2 8/9] drm/bridge: analogix_dp: Add support for RK3576 Damon Ding
2026-03-23 16:14   ` Luca Ceresoli
2026-03-20  0:45 ` [PATCH v2 9/9] drm/rockchip: " Damon Ding
2026-03-23 16:14   ` Luca Ceresoli

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=42c0641f-2e37-4ca4-a1ae-e8fde24c8460@rock-chips.com \
    --to=damon.ding@rock-chips.com \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=airlied@gmail.com \
    --cc=alchark@gmail.com \
    --cc=amadeus@jmu.edu.cn \
    --cc=andrzej.hajda@intel.com \
    --cc=andy.yan@rock-chips.com \
    --cc=conor+dt@kernel.org \
    --cc=cristian.ciocaltea@collabora.com \
    --cc=devicetree@vger.kernel.org \
    --cc=dianders@chromium.org \
    --cc=didi.debian@cknow.org \
    --cc=dmitry.baryshkov@oss.qualcomm.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=heiko.stuebner@cherry.de \
    --cc=heiko@sntech.de \
    --cc=hjc@rock-chips.com \
    --cc=jernej.skrabec@gmail.com \
    --cc=jonas@kwiboo.se \
    --cc=kever.yang@rock-chips.com \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=luca.ceresoli@bootlin.com \
    --cc=m.szyprowski@samsung.com \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=michael.riesch@collabora.com \
    --cc=mripard@kernel.org \
    --cc=neil.armstrong@linaro.org \
    --cc=nicolas.frattaroli@collabora.com \
    --cc=rfoss@kernel.org \
    --cc=robh@kernel.org \
    --cc=sebastian.reichel@collabora.com \
    --cc=simona@ffwll.ch \
    --cc=tomeu@tomeuvizoso.net \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®