Pekka Enberg wrote: >This patch renames the obj_reallen() function to obj_size() which makes the >code more readable. > > > I disagree. There are two different object length: - the amount of memory available for the user. This is stored in cachep->reallen. - the amount of memory allocated internally. Due to redzoning, this can be larger than the amount available. Stored in cachep->objsize. With your change, cachep->objsize is the internal allocation and obj_size(cachep) is the user visible part. This reduces the readability. I agree that the names obj_size and reallen are bad. What about the attached patch? Signed-Off-By: Manfred Spraul