From: Andrzej Hajda <a.hajda@samsung.com>
To: Eric Anholt <eric@anholt.net>,
dri-devel@lists.freedesktop.org,
Archit Taneja <architt@codeaurora.org>,
Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
Thierry Reding <thierry.reding@gmail.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/8] drm/bridge: Add a devm_ allocator for panel bridge.
Date: Thu, 29 Jun 2017 11:30:42 +0200 [thread overview]
Message-ID: <4421363a-db3d-b724-012c-ecef8dc969f5@samsung.com> (raw)
In-Reply-To: <20170627195839.3338-5-eric@anholt.net>
On 27.06.2017 21:58, Eric Anholt wrote:
> This will let drivers reduce the error cleanup they need, in
> particular the "is_panel_bridge" flag.
>
> Signed-off-by: Eric Anholt <eric@anholt.net>
> ---
> drivers/gpu/drm/bridge/panel.c | 30 ++++++++++++++++++++++++++++++
> include/drm/drm_bridge.h | 3 +++
> 2 files changed, 33 insertions(+)
>
> diff --git a/drivers/gpu/drm/bridge/panel.c b/drivers/gpu/drm/bridge/panel.c
> index 67fe19e5a9c6..cdf367d2653a 100644
> --- a/drivers/gpu/drm/bridge/panel.c
> +++ b/drivers/gpu/drm/bridge/panel.c
> @@ -198,3 +198,33 @@ void drm_panel_bridge_remove(struct drm_bridge *bridge)
> devm_kfree(panel_bridge->panel->dev, bridge);
> }
> EXPORT_SYMBOL(drm_panel_bridge_remove);
> +
> +static void devm_drm_panel_bridge_release(struct device *dev, void *res)
> +{
> + struct drm_bridge *bridge = *(struct drm_bridge **)res;
> +
> + drm_panel_bridge_remove(bridge);
I guess more elegant would be:
struct drm_bridge **bridge = res;
drm_panel_bridge_remove(*bridge);
I am still not convinced to the idea of this panel_bridge stuff, but
this is different issue :)
Anyway:
Reviewed-by: Andrzej Hajda <a.hajda@samsung.com>
--
Regards
Andrzej
> +}
> +
> +struct drm_bridge *devm_drm_panel_bridge_add(struct device *dev,
> + struct drm_panel *panel,
> + u32 connector_type)
> +{
> + struct drm_bridge **ptr, *bridge;
> +
> + ptr = devres_alloc(devm_drm_panel_bridge_release, sizeof(*ptr),
> + GFP_KERNEL);
> + if (!ptr)
> + return ERR_PTR(-ENOMEM);
> +
> + bridge = drm_panel_bridge_add(panel, connector_type);
> + if (!IS_ERR(bridge)) {
> + *ptr = bridge;
> + devres_add(dev, ptr);
> + } else {
> + devres_free(ptr);
> + }
> +
> + return bridge;
> +}
> +EXPORT_SYMBOL(devm_drm_panel_bridge_add);
> diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h
> index 1dc94d5392e2..6522d4cbc9d9 100644
> --- a/include/drm/drm_bridge.h
> +++ b/include/drm/drm_bridge.h
> @@ -268,6 +268,9 @@ void drm_bridge_enable(struct drm_bridge *bridge);
> struct drm_bridge *drm_panel_bridge_add(struct drm_panel *panel,
> u32 connector_type);
> void drm_panel_bridge_remove(struct drm_bridge *bridge);
> +struct drm_bridge *devm_drm_panel_bridge_add(struct device *dev,
> + struct drm_panel *panel,
> + u32 connector_type);
> #endif
>
> #endif
next prev parent reply other threads:[~2017-06-29 9:30 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-27 19:58 [PATCH 0/8] RPi touchscreen panel driver v4 Eric Anholt
2017-06-27 19:58 ` [PATCH 1/8] drm/vc4: Fix DSI T_INIT timing Eric Anholt
2017-06-29 9:02 ` Andrzej Hajda
2017-06-27 19:58 ` [PATCH 2/8] drm/vc4: Fix misleading name of the continuous flag Eric Anholt
2017-06-29 9:03 ` Andrzej Hajda
2017-06-27 19:58 ` [PATCH 3/8] drm/vc4: Use drm_mode_vrefresh() in DSI fixup, in case vrefresh is 0 Eric Anholt
2017-06-29 9:24 ` Andrzej Hajda
2017-06-27 19:58 ` [PATCH 4/8] drm/bridge: Add a devm_ allocator for panel bridge Eric Anholt
2017-06-29 9:30 ` Andrzej Hajda [this message]
2017-06-27 19:58 ` [PATCH 5/8] drm/vc4: Delay DSI host registration until the panel has probed Eric Anholt
2017-06-29 9:42 ` Andrzej Hajda
2017-06-27 19:58 ` [PATCH 6/8] drm: Allow DSI devices to be registered before the host registers Eric Anholt
2017-06-29 5:03 ` Archit Taneja
2017-06-29 10:39 ` Andrzej Hajda
2017-06-29 15:22 ` Eric Anholt
2017-06-30 8:48 ` Andrzej Hajda
2017-07-03 10:56 ` Archit Taneja
2017-07-14 23:01 ` Eric Anholt
2017-07-17 13:39 ` Archit Taneja
2017-07-14 22:58 ` Eric Anholt
2017-07-17 4:26 ` Archit Taneja
2017-07-18 20:13 ` Eric Anholt
2017-07-19 3:29 ` Archit Taneja
2017-08-04 9:29 ` Boris Brezillon
2017-06-27 19:58 ` [PATCH 7/8] dt-bindings: Document the Raspberry Pi Touchscreen nodes Eric Anholt
2017-06-27 19:58 ` [PATCH 8/8] drm/panel: Add support for the Raspberry Pi 7" Touchscreen Eric Anholt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4421363a-db3d-b724-012c-ecef8dc969f5@samsung.com \
--to=a.hajda@samsung.com \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=architt@codeaurora.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=eric@anholt.net \
--cc=linux-kernel@vger.kernel.org \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®