Hello. Andrew Morton wrote: > Separate functions input_enable_device(struct input_handle *handle) and > input_disable_device(struct input_handle *handle) would be preferred. Right, and here it goes. --- add input_enable_device() and input_disable_device() Signed-off-by: Stas Sergeev CC: Dmitry Torokhov CC: Vojtech Pavlik