From: Grygorii Strashko <grygorii.strashko@ti.com>
To: Thierry Reding <thierry.reding@gmail.com>,
Linus Walleij <linus.walleij@linaro.org>
Cc: Jonathan Hunter <jonathanh@nvidia.com>,
<linux-gpio@vger.kernel.org>, <linux-tegra@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 00/16] gpio: Tight IRQ chip integration and banked infrastructure
Date: Thu, 28 Sep 2017 09:22:17 -0500 [thread overview]
Message-ID: <44cf41e3-834e-ddb3-4c9e-8ab00e0866cb@ti.com> (raw)
In-Reply-To: <20170928095628.21966-1-thierry.reding@gmail.com>
On 09/28/2017 04:56 AM, Thierry Reding wrote:
> From: Thierry Reding <treding@nvidia.com>
>
> Hi Linus,
>
> here's the latest series of patches that implement the tighter IRQ chip
> integration as well as the banked GPIO infrastructure that we had
> discussed a couple of weeks/months back.
>
> The first couple of patches are mostly preparatory work in order to
> consolidate all IRQ chip related fields in a new structure and create
> the base functionality for adding IRQ chips.
>
> After that, I've added the Tegra186 GPIO support patch that makes use of
> the new tight integration.
>
> To round things off the new banked GPIO infrastructure is added (along
> with some more preparatory work), followed by the conversion of the two
> Tegra GPIO drivers to the new infrastructure.
Hm. So you've ignored my comments [1].
Sry, but I do not agree with this series.
- no prof that it can be re-used by other drivers than tegra
(at least I do not see reasons to re-use it for any TI drivers)
- no split
- all GPIO IRQs mapped statically
- irq->map[offset + j] = irq->parents[parent]; holds IRQs for all pins
which is waste of memory
- DT binding changes not documented and no DT examples
- below is ugly ;)
+ bank = (spec[0] >> gc->of_gpio_bank_mask) & gc->of_gpio_bank_shift;
+ pin = (spec[0] >> gc->of_gpio_pin_mask) & gc->of_gpio_pin_shift;
[1] https://lkml.org/lkml/2017/9/15/442
>
> Changes in v2:
> - rename pins to lines for consistent terminology
> - rename gpio_irq_chip_banked_handler() to
> gpio_irq_chip_banked_chained_handler()
>
> Thierry
>
> Thierry Reding (16):
> gpio: Implement tighter IRQ chip integration
> gpio: Move irqchip into struct gpio_irq_chip
> gpio: Move irqdomain into struct gpio_irq_chip
> gpio: Move irq_base to struct gpio_irq_chip
> gpio: Move irq_handler to struct gpio_irq_chip
> gpio: Move irq_default_type to struct gpio_irq_chip
> gpio: Move irq_chained_parent to struct gpio_irq_chip
> gpio: Move irq_nested into struct gpio_irq_chip
> gpio: Move irq_valid_mask into struct gpio_irq_chip
> gpio: Move lock_key into struct gpio_irq_chip
> gpio: Add Tegra186 support
> gpio: omap: Fix checkpatch warnings
> gpio: omap: Rename struct gpio_bank to struct omap_gpio_bank
> gpio: Add support for banked GPIO controllers
> gpio: tegra: Use banked GPIO infrastructure
> gpio: tegra186: Use banked GPIO infrastructure
>
> Documentation/gpio/driver.txt | 6 +-
> drivers/bcma/driver_gpio.c | 2 +-
> drivers/gpio/Kconfig | 10 +
> drivers/gpio/Makefile | 1 +
> drivers/gpio/gpio-104-dio-48e.c | 2 +-
> drivers/gpio/gpio-104-idi-48.c | 2 +-
> drivers/gpio/gpio-104-idio-16.c | 2 +-
> drivers/gpio/gpio-adnp.c | 2 +-
> drivers/gpio/gpio-altera.c | 4 +-
> drivers/gpio/gpio-aspeed.c | 6 +-
> drivers/gpio/gpio-ath79.c | 2 +-
> drivers/gpio/gpio-brcmstb.c | 2 +-
> drivers/gpio/gpio-crystalcove.c | 2 +-
> drivers/gpio/gpio-dln2.c | 2 +-
> drivers/gpio/gpio-ftgpio010.c | 2 +-
> drivers/gpio/gpio-ingenic.c | 2 +-
> drivers/gpio/gpio-intel-mid.c | 2 +-
> drivers/gpio/gpio-lynxpoint.c | 2 +-
> drivers/gpio/gpio-max732x.c | 2 +-
> drivers/gpio/gpio-merrifield.c | 2 +-
> drivers/gpio/gpio-omap.c | 222 ++++++-----
> drivers/gpio/gpio-pca953x.c | 2 +-
> drivers/gpio/gpio-pcf857x.c | 2 +-
> drivers/gpio/gpio-pci-idio-16.c | 2 +-
> drivers/gpio/gpio-pl061.c | 2 +-
> drivers/gpio/gpio-rcar.c | 2 +-
> drivers/gpio/gpio-reg.c | 4 +-
> drivers/gpio/gpio-stmpe.c | 6 +-
> drivers/gpio/gpio-tc3589x.c | 2 +-
> drivers/gpio/gpio-tegra.c | 203 +++++-----
> drivers/gpio/gpio-tegra186.c | 571 ++++++++++++++++++++++++++++
> drivers/gpio/gpio-vf610.c | 2 +-
> drivers/gpio/gpio-wcove.c | 2 +-
> drivers/gpio/gpio-ws16c48.c | 2 +-
> drivers/gpio/gpio-xgene-sb.c | 2 +-
> drivers/gpio/gpio-xlp.c | 2 +-
> drivers/gpio/gpio-zx.c | 2 +-
> drivers/gpio/gpio-zynq.c | 2 +-
> drivers/gpio/gpiolib-of.c | 101 +++++
> drivers/gpio/gpiolib.c | 320 ++++++++++++++--
> drivers/pinctrl/bcm/pinctrl-bcm2835.c | 5 +-
> drivers/pinctrl/bcm/pinctrl-iproc-gpio.c | 2 +-
> drivers/pinctrl/intel/pinctrl-baytrail.c | 6 +-
> drivers/pinctrl/intel/pinctrl-cherryview.c | 6 +-
> drivers/pinctrl/intel/pinctrl-intel.c | 2 +-
> drivers/pinctrl/mvebu/pinctrl-armada-37xx.c | 4 +-
> drivers/pinctrl/nomadik/pinctrl-nomadik.c | 4 +-
> drivers/pinctrl/pinctrl-amd.c | 2 +-
> drivers/pinctrl/pinctrl-at91.c | 2 +-
> drivers/pinctrl/pinctrl-coh901.c | 2 +-
> drivers/pinctrl/pinctrl-mcp23s08.c | 2 +-
> drivers/pinctrl/pinctrl-oxnas.c | 2 +-
> drivers/pinctrl/pinctrl-pic32.c | 2 +-
> drivers/pinctrl/pinctrl-pistachio.c | 2 +-
> drivers/pinctrl/pinctrl-st.c | 2 +-
> drivers/pinctrl/pinctrl-sx150x.c | 2 +-
> drivers/pinctrl/qcom/pinctrl-msm.c | 2 +-
> drivers/pinctrl/sirf/pinctrl-atlas7.c | 2 +-
> drivers/pinctrl/sirf/pinctrl-sirf.c | 2 +-
> drivers/pinctrl/spear/pinctrl-plgpio.c | 2 +-
> drivers/platform/x86/intel_int0002_vgpio.c | 6 +-
> include/linux/gpio/driver.h | 272 +++++++++++--
> include/linux/of_gpio.h | 10 +
> 63 files changed, 1505 insertions(+), 348 deletions(-)
> create mode 100644 drivers/gpio/gpio-tegra186.c
>
--
regards,
-grygorii
next prev parent reply other threads:[~2017-09-28 14:22 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-28 9:56 Thierry Reding
2017-09-28 9:56 ` [PATCH v2 01/16] gpio: Implement tighter IRQ chip integration Thierry Reding
2017-09-28 14:22 ` Grygorii Strashko
2017-10-10 22:56 ` Grygorii Strashko
2017-09-28 9:56 ` [PATCH v2 02/16] gpio: Move irqchip into struct gpio_irq_chip Thierry Reding
2017-09-28 9:56 ` [PATCH v2 03/16] gpio: Move irqdomain " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 04/16] gpio: Move irq_base to " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 05/16] gpio: Move irq_handler " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 06/16] gpio: Move irq_default_type " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 07/16] gpio: Move irq_chained_parent " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 08/16] gpio: Move irq_nested into " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 09/16] gpio: Move irq_valid_mask " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 10/16] gpio: Move lock_key " Thierry Reding
2017-09-28 9:56 ` [PATCH v2 11/16] gpio: Add Tegra186 support Thierry Reding
2017-09-28 9:56 ` [PATCH v2 12/16] gpio: omap: Fix checkpatch warnings Thierry Reding
2017-09-28 9:56 ` [PATCH v2 13/16] gpio: omap: Rename struct gpio_bank to struct omap_gpio_bank Thierry Reding
2017-09-28 9:56 ` [PATCH v2 14/16] gpio: Add support for banked GPIO controllers Thierry Reding
2017-10-09 21:52 ` Grygorii Strashko
2017-10-10 11:00 ` Thierry Reding
2017-10-10 22:12 ` Grygorii Strashko
2017-09-28 9:56 ` [PATCH v2 15/16] gpio: tegra: Use banked GPIO infrastructure Thierry Reding
2017-10-09 21:22 ` Grygorii Strashko
2017-10-10 10:27 ` Thierry Reding
2017-10-10 19:31 ` Grygorii Strashko
2017-09-28 9:56 ` [PATCH v2 16/16] gpio: tegra186: " Thierry Reding
2017-09-28 14:22 ` Grygorii Strashko [this message]
2017-10-02 7:55 ` [PATCH v2 00/16] gpio: Tight IRQ chip integration and banked infrastructure Linus Walleij
2017-10-03 18:26 ` Grygorii Strashko
2017-10-05 11:19 ` Linus Walleij
2017-10-05 11:14 ` Linus Walleij
2017-10-06 11:07 ` Thierry Reding
2017-10-06 11:11 ` Thierry Reding
2017-10-09 21:56 ` Grygorii Strashko
2017-10-10 11:27 ` Thierry Reding
2017-10-10 22:56 ` Grygorii Strashko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=44cf41e3-834e-ddb3-4c9e-8ab00e0866cb@ti.com \
--to=grygorii.strashko@ti.com \
--cc=jonathanh@nvidia.com \
--cc=linus.walleij@linaro.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tegra@vger.kernel.org \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®