mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Waiman Long <llong@redhat.com>
To: Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Thomas Gleixner <tglx@linutronix.de>
Cc: linux-kernel@vger.kernel.org,
	"André Almeida" <andrealmeid@igalia.com>,
	"Darren Hart" <dvhart@infradead.org>,
	"Davidlohr Bueso" <dave@stgolabs.net>,
	"Ingo Molnar" <mingo@redhat.com>,
	"Juri Lelli" <juri.lelli@redhat.com>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Valentin Schneider" <vschneid@redhat.com>
Subject: Re: [PATCH] futex: Use a hashmask instead of hashsize.
Date: Wed, 26 Feb 2025 09:37:26 -0500	[thread overview]
Message-ID: <44f36f13-4ce6-47ce-9423-9e4cceda7443@redhat.com> (raw)
In-Reply-To: <20250226091057.bX8vObR4@linutronix.de>

On 2/26/25 4:10 AM, Sebastian Andrzej Siewior wrote:
> The global hash uses futex_hashsize to save the amount of the hash
> buckets that have been allocated during system boot. On each
> futex_hash() invocation this number is substracted by one to get the
> mask. This can be optimized by saving directly the mask avoiding the
> substraction on each futex_hash() invocation.
>
> Rename futex_hashsize to futex_hashmask and save the mask of the
> allocated hash map.
>
> Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
> ---
>
> Split from the "local hash" series.
>
>   kernel/futex/core.c | 21 +++++++++++----------
>   1 file changed, 11 insertions(+), 10 deletions(-)
>
> diff --git a/kernel/futex/core.c b/kernel/futex/core.c
> index 3db8567f5a44e..cca15859a50be 100644
> --- a/kernel/futex/core.c
> +++ b/kernel/futex/core.c
> @@ -50,10 +50,10 @@
>    */
>   static struct {
>   	struct futex_hash_bucket *queues;
> -	unsigned long            hashsize;
> +	unsigned long            hashmask;
>   } __futex_data __read_mostly __aligned(2*sizeof(long));
>   #define futex_queues   (__futex_data.queues)
> -#define futex_hashsize (__futex_data.hashsize)
> +#define futex_hashmask (__futex_data.hashmask)
>   
>   
>   /*
> @@ -119,7 +119,7 @@ struct futex_hash_bucket *futex_hash(union futex_key *key)
>   	u32 hash = jhash2((u32 *)key, offsetof(typeof(*key), both.offset) / 4,
>   			  key->both.offset);
>   
> -	return &futex_queues[hash & (futex_hashsize - 1)];
> +	return &futex_queues[hash & futex_hashmask];
>   }
>   
>   
> @@ -1127,27 +1127,28 @@ void futex_exit_release(struct task_struct *tsk)
>   
>   static int __init futex_init(void)
>   {
> +	unsigned long hashsize, i;
>   	unsigned int futex_shift;
> -	unsigned long i;
>   
>   #ifdef CONFIG_BASE_SMALL
> -	futex_hashsize = 16;
> +	hashsize = 16;
>   #else
> -	futex_hashsize = roundup_pow_of_two(256 * num_possible_cpus());
> +	hashsize = roundup_pow_of_two(256 * num_possible_cpus());
>   #endif
>   
>   	futex_queues = alloc_large_system_hash("futex", sizeof(*futex_queues),
> -					       futex_hashsize, 0, 0,
> +					       hashsize, 0, 0,
>   					       &futex_shift, NULL,
> -					       futex_hashsize, futex_hashsize);
> -	futex_hashsize = 1UL << futex_shift;
> +					       hashsize, hashsize);
> +	hashsize = 1UL << futex_shift;
>   
> -	for (i = 0; i < futex_hashsize; i++) {
> +	for (i = 0; i < hashsize; i++) {
>   		atomic_set(&futex_queues[i].waiters, 0);
>   		plist_head_init(&futex_queues[i].chain);
>   		spin_lock_init(&futex_queues[i].lock);
>   	}
>   
> +	futex_hashmask = hashsize - 1;
>   	return 0;
>   }
>   core_initcall(futex_init);

LGTM

Reviewed-by: Waiman Long <longman@redhat.com>


  reply	other threads:[~2025-02-26 14:37 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-26  9:10 Sebastian Andrzej Siewior
2025-02-26 14:37 ` Waiman Long [this message]
2025-02-26 15:11 ` [tip: locking/futex] " tip-bot2 for Sebastian Andrzej Siewior
2025-02-27  1:54 ` [PATCH] " André Almeida

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=44f36f13-4ce6-47ce-9423-9e4cceda7443@redhat.com \
    --to=llong@redhat.com \
    --cc=andrealmeid@igalia.com \
    --cc=bigeasy@linutronix.de \
    --cc=dave@stgolabs.net \
    --cc=dvhart@infradead.org \
    --cc=juri.lelli@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=vschneid@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®