mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Robert Peterson <rpeterso@redhat.com>
To: Paulo Marques <pmarques@grupopie.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2.6.21-rc1] Extend print_symbol capability
Date: Fri, 02 Mar 2007 11:24:34 -0600	[thread overview]
Message-ID: <45E85DD2.8010905@redhat.com> (raw)
In-Reply-To: <45E84C95.3060604@grupopie.com>

Paulo Marques wrote:
> I don't like this name much :(
>
> We already have kallsyms_lookup and kallsyms_lookup_name. The name of 
> this function should imply that it will print the formatted result 
> into the buffer, not just lookup a symbol.
>
> Maybe "__sprint_symbol", and change the interface to 
> "__sprint_symbol(char *buffer, unsigned long addr)"?
I'm not sure I like the leading __.  In the print_symbol case, I think 
the function
was given a leading __ so that code referencing print_symbol would use the
macro which formulates the call into __print_symbol.  I don't mind 
sprint_symbol
though.  Since Andrew Morton included the patch, I'll defer to his judgment.
>> +static inline void lookup_symbol(unsigned long addr, char *buffer)
>> +{
>> +       return NULL;
>> +}
> Returning NULL in a function returning "void" doesn't seem right :P
You're right.  This should just be a simple "return;".  My bad.  Good catch.
Since Andrew Morton has already included this patch, I'll let him
make this change if he sees fit.

Regards,

Bob Peterson
Red Hat Cluster Suite


      reply	other threads:[~2007-03-02 17:24 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-03-01 21:25 Robert Peterson
2007-03-02 16:11 ` Paulo Marques
2007-03-02 17:24   ` Robert Peterson [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=45E85DD2.8010905@redhat.com \
    --to=rpeterso@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmarques@grupopie.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome