From: Stefan Richter <stefanr@s5r6.in-berlin.de>
To: "Robert P. J. Day" <rpjday@mindspring.com>
Cc: Artem Bityutskiy <dedekind@yandex.ru>,
Randy Dunlap <randy.dunlap@oracle.com>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: the usage of DEBUG_DRIVER seems ambiguous
Date: Fri, 09 Mar 2007 17:25:48 +0100 [thread overview]
Message-ID: <45F18A8C.6020209@s5r6.in-berlin.de> (raw)
In-Reply-To: <Pine.LNX.4.64.0703090916410.3143@CPE00045a9c397f-CM001225dbafb6>
Robert P. J. Day wrote:
> On Fri, 9 Mar 2007, Artem Bityutskiy wrote:
>> Randy Dunlap wrote:
>> > The ones in drivers/net/ are just local driver debug controls.
>> > They happen to have the same name as a (likely newer) kconfig symbol.
>> >
>> > Is there a real problem that needs to be fixed?
>>
>> Renaming them just for the sake of being less confusing makes sense.
...
> if someone wants to make a suggestion, i can submit a simple renaming
> patch.
If a driver or subsystem already uses a prefix to have an own namespace
for macros, functions, structs and so on, a local DEBUG_DRIVER could
become something like LOCALPREFIX_DEBUG. If there is a narrow usage of
the macro, e.g. to indicate a debug level, it could become something
speaking like LOCALPREFIX_DEBUG_LEVEL. --- However, after looking at the
actual occurrences of DEBUG_DRIVER, I see that this recommendation
doesn't really apply that well.
>From your initial post:
| $ $ grep -rw DEBUG_DRIVER *
| drivers/net/sunlance.c:#undef DEBUG_DRIVER
This is an old forgotten rest of earlier debug code. See here for evidence:
http://lxr.linux.no/source/drivers/net/sunlance.c?v=2.2.26#L791
791 #ifdef DEBUG_DRIVER
792 printk (KERN_DEBUG "Lance restart=%d\n", status);
793 #endif
This usage of DEBUG_DRIVER isn't there anymore. Therefore simply delete
the remaining occurrence:
-#undef DEBUG_DRIVER
| drivers/net/a2065.c:#ifdef DEBUG_DRIVER
| drivers/net/a2065.c:#ifdef DEBUG_DRIVER
Rename to A2065_DEBUG or LANCE_DEBUG. Two more alternatives:
-#ifdef DEBUG_DRIVER
+#if 0 /* debug */
or
-#ifdef DEBUG_DRIVER
- years_old_debug_cruft_nobody_enables_anymore();
-#endif
Needless to say, the maintainer certainly wants to ACK/NAK this.
| drivers/net/7990.c:#ifdef DEBUG_DRIVER
| drivers/net/7990.c:#ifdef DEBUG_DRIVER
Exactly like with a2065.c.
| drivers/base/Kconfig:config DEBUG_DRIVER
According to where it is defined, CONFIG_DEBUG_DRIVER should only occur
in drivers/base/* (and some defconfigs outside of drivers/base/).
| ...
More hits from LXR:
drivers/isdn/hardware/eicon/dbgioctl.h
Where is this header file used anyway? Can the entire file be deleted?
drivers/isdn/gigaset/gigaset.h (definition as enum item)
drivers/isdn/gigaset/common.c (multiple uses)
If the overlap with CONFIG_DEBUG_DRIVER bothers you, rename it to
DEBUG_DRIVER_STRUCT or whatever.
--
Stefan Richter
-=====-=-=== --== --===
http://arcgraph.de/sr/
prev parent reply other threads:[~2007-03-09 16:26 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-03-08 0:44 Robert P. J. Day
2007-03-08 19:18 ` Randy Dunlap
2007-03-08 19:59 ` Robert P. J. Day
2007-03-09 14:06 ` Artem Bityutskiy
2007-03-09 14:19 ` Robert P. J. Day
2007-03-09 16:25 ` Stefan Richter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=45F18A8C.6020209@s5r6.in-berlin.de \
--to=stefanr@s5r6.in-berlin.de \
--cc=dedekind@yandex.ru \
--cc=linux-kernel@vger.kernel.org \
--cc=randy.dunlap@oracle.com \
--cc=rpjday@mindspring.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®