From: "Ken'ichi Ohmichi" <oomichi@mxs.nes.nec.co.jp>
To: lkml <linux-kernel@vger.kernel.org>,
kexec-ml <kexec@lists.infradead.org>
Subject: [PATCH 3/5] Add "VMCOREINFO_" to all the call for vmcoreinfo_append_str()
Date: Fri, 16 Nov 2007 11:33:14 +0900 [thread overview]
Message-ID: <473D016A.7010107@mxs.nes.nec.co.jp> (raw)
In-Reply-To: <473CFE14.3010400@mxs.nes.nec.co.jp>
For readability, all the calls to vmcoreinfo_append_str() are changed to macros
having a prefix "VMCOREINFO_".
This discussion is the following:
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.3/0584.html
Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>
---
diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h
--- a/include/linux/kexec.h 2007-11-12 11:04:09.000000000 +0900
+++ b/include/linux/kexec.h 2007-11-12 11:04:22.000000000 +0900
@@ -127,6 +127,10 @@ void vmcoreinfo_append_str(const char *f
__attribute__ ((format (printf, 1, 2)));
unsigned long paddr_vmcoreinfo_note(void);
+#define VMCOREINFO_OSRELEASE(name) \
+ vmcoreinfo_append_str("OSRELEASE=%s\n", #name)
+#define VMCOREINFO_PAGESIZE(value) \
+ vmcoreinfo_append_str("PAGESIZE=%ld\n", value)
#define VMCOREINFO_SYMBOL(name) \
vmcoreinfo_append_str("SYMBOL(%s)=%lx\n", #name, (unsigned long)&name)
#define VMCOREINFO_SIZE(name) \
diff -rpuN a/kernel/kexec.c b/kernel/kexec.c
--- a/kernel/kexec.c 2007-11-12 11:04:11.000000000 +0900
+++ b/kernel/kexec.c 2007-11-12 11:04:22.000000000 +0900
@@ -1361,8 +1361,8 @@ unsigned long __attribute__ ((weak)) pad
static int __init crash_save_vmcoreinfo_init(void)
{
- vmcoreinfo_append_str("OSRELEASE=%s\n", init_uts_ns.name.release);
- vmcoreinfo_append_str("PAGESIZE=%ld\n", PAGE_SIZE);
+ VMCOREINFO_OSRELEASE(init_uts_ns.name.release);
+ VMCOREINFO_PAGESIZE(PAGE_SIZE);
VMCOREINFO_SYMBOL(init_uts_ns);
VMCOREINFO_SYMBOL(node_online_map);
_
next prev parent reply other threads:[~2007-11-16 2:35 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <473CFE14.3010400@mxs.nes.nec.co.jp>
2007-11-16 2:33 ` [PATCH 1/5] Rename vmcoreinfo's macros returning the size Ken'ichi Ohmichi
2007-11-16 18:26 ` Simon Horman
2007-11-16 2:33 ` [PATCH 2/5] Use the existing offsetof() for VMCOREINFO_OFFSET() Ken'ichi Ohmichi
2007-11-16 18:54 ` Simon Horman
2007-11-16 2:33 ` Ken'ichi Ohmichi [this message]
2007-11-16 18:55 ` [PATCH 3/5] Add "VMCOREINFO_" to all the call for vmcoreinfo_append_str() Simon Horman
2007-11-16 2:33 ` [PATCH 4/5] Fix the configuration dependencies Ken'ichi Ohmichi
2007-11-16 16:25 ` Simon Horman
2007-11-21 2:50 ` Ken'ichi Ohmichi
2007-11-26 7:58 ` Andrew Morton
2007-11-27 9:38 ` Ken'ichi Ohmichi
2007-11-27 18:18 ` Christoph Lameter
2007-11-16 2:33 ` [PATCH 5/5] Add the array length of "free_list" for filtering free pages Ken'ichi Ohmichi
2007-11-16 19:16 ` Simon Horman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=473D016A.7010107@mxs.nes.nec.co.jp \
--to=oomichi@mxs.nes.nec.co.jp \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®