From: Zhihao Cheng <chengzhihao1@huawei.com>
To: Waqar Hameed <waqar.hameed@axis.com>,
Richard Weinberger <richard@nod.at>
Cc: <kernel@axis.com>, <linux-mtd@lists.infradead.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ubifs: Move update of cnt in get_znodes_to_commit
Date: Fri, 18 Oct 2024 09:24:03 +0800 [thread overview]
Message-ID: <4751d3df-99a6-ec67-1175-ea5375290726@huawei.com> (raw)
In-Reply-To: <ebf1570e3d28462a97b1a595794e1969a4c27d81.1729191143.git.waqar.hameed@axis.com>
在 2024/10/18 2:41, Waqar Hameed 写道:
> There is no need to update `cnt` for the first dirty node just before
> the loop, and then again update it at the end of each iteration for the
> next dirty nodes. Just update `cnt` at the beginning of each iteration
> instead. This way, the first iteration will count the first dirty node
> and any subsequent iterations will count the next dirty nodes.
Well, from my own view, I prefer the orignal style because it looks more
readable.
c->cnext = find_first_dirty(c->zroot.znode);
znode = c->enext = c->cnext;
cnt += 1; // We get the first one.
while (1) {
cnext = find_next_dirty(znode);
znode = cnext;
cnt += 1; // We get another one.
}
After applying this patch, the intention of 'cnt' updating is not so
obviously. However, it does reduce the duplicated codes. I will add an
acked-by to let Richard determine whether or not apply this patch.
Acked-by: Zhihao Cheng <chengzhihao1@huawei.com>
>
> Signed-off-by: Waqar Hameed <waqar.hameed@axis.com>
> ---
> fs/ubifs/tnc_commit.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/fs/ubifs/tnc_commit.c b/fs/ubifs/tnc_commit.c
> index a55e04822d16..d42f7829389c 100644
> --- a/fs/ubifs/tnc_commit.c
> +++ b/fs/ubifs/tnc_commit.c
> @@ -650,8 +650,8 @@ static int get_znodes_to_commit(struct ubifs_info *c)
> dbg_cmt("no znodes to commit");
> return 0;
> }
> - cnt += 1;
> while (1) {
> + cnt += 1;
> ubifs_assert(c, !ubifs_zn_cow(znode));
> __set_bit(COW_ZNODE, &znode->flags);
> znode->alt = 0;
> @@ -664,7 +664,6 @@ static int get_znodes_to_commit(struct ubifs_info *c)
> znode->ciip = znode->iip;
> znode->cnext = cnext;
> znode = cnext;
> - cnt += 1;
> }
> dbg_cmt("committing %d znodes", cnt);
> ubifs_assert(c, cnt == atomic_long_read(&c->dirty_zn_cnt));
>
next prev parent reply other threads:[~2024-10-18 1:24 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-17 18:41 Waqar Hameed
2024-10-18 1:24 ` Zhihao Cheng [this message]
2024-11-06 16:48 ` Waqar Hameed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4751d3df-99a6-ec67-1175-ea5375290726@huawei.com \
--to=chengzhihao1@huawei.com \
--cc=kernel@axis.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=richard@nod.at \
--cc=waqar.hameed@axis.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®