From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S937639AbdAKMJO (ORCPT ); Wed, 11 Jan 2017 07:09:14 -0500 Received: from mail-wj0-f193.google.com ([209.85.210.193]:33283 "EHLO mail-wj0-f193.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751756AbdAKMJN (ORCPT ); Wed, 11 Jan 2017 07:09:13 -0500 Subject: Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with nandc instead of nand To: Boris Brezillon References: <1479732328-18363-1-git-send-email-boris.brezillon@free-electrons.com> <1479732328-18363-5-git-send-email-boris.brezillon@free-electrons.com> <8fb86bb7-425a-3897-2d1d-7277e94918ec@gmail.com> <20170111084613.69e80a40@bbrezillon> Cc: Richard Weinberger , linux-mtd@lists.infradead.org, Peter Pan , David Woodhouse , Brian Norris , Cyrille Pitchen , linux-kernel@vger.kernel.org, Ezequiel Garcia , Kelvin Cheung From: Marek Vasut Message-ID: <47760b42-607c-bcae-18b9-3ede5773125a@gmail.com> Date: Wed, 11 Jan 2017 13:09:09 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.4.0 MIME-Version: 1.0 In-Reply-To: <20170111084613.69e80a40@bbrezillon> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/11/2017 08:46 AM, Boris Brezillon wrote: > On Tue, 10 Jan 2017 20:08:23 +0100 > Marek Vasut wrote: > >> On 11/21/2016 01:45 PM, Boris Brezillon wrote: >>> Some raw NAND function names conflict with names defined in nand.h. >>> Prefix all those functions with nandc (for nand chip) instead of nand so >>> we can include nand.h from rawnand.h >>> >>> Signed-off-by: Boris Brezillon >> >> Nit, nand and nandc is quite confusing, why not call it nand_chip in full? >> > > Indeed, the name is confusing as hell, I just tried to keep it > short but that's probably not a good idea. > Maybe I should just prefix/suffix the new functions with nanddev instead > of changing the existing ones. What do you think? That'd be less intrusive, but tbh, if the name is descriptive enough, I don't care either way. What does 'nanddev' imply though ? NAND device as in physical device or chip or just a kernel device object ? :-) -- Best regards, Marek Vasut