Andrew Morton wrote: > I already added gti-ubifs.patch to the -mm lineup. I haven't yet tried > pulling, merging or compiling it. Cool. > I'd suggest that you just retain this patch in your tree. > >> Should I amend the reiser4 patch correspondingly for you? > > That would be nice, if you have time, thanks. I've split the original patch on 3 pieces: 1. VFS: move inode_lock into sync_sb_inodes 2. VFS: export sync_sb_inodes 3. VFS: introduce sync_inodes superblock operation The first 2 are exactly what UBIFS also needs. The third one is only needed for Reiser4. The patches are attached. I am not sure this is the best way to split. The second patch could just export sync_sb_inodes() without renaming it to generic_sync_sb_inodes(). But in this case we would have more complex third patch and more dependencies between reiser4 and ubifs. What is better? -- Best Regards, Artem Bityutskiy (Артём Битюцкий)