From: "Jason-JH Lin (林睿祥)" <Jason-JH.Lin@mediatek.com>
To: "angelogioacchino.delregno@collabora.com"
<angelogioacchino.delregno@collabora.com>,
"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>
Cc: "linux-mediatek@lists.infradead.org"
<linux-mediatek@lists.infradead.org>,
"Singo Chang (張興國)" <Singo.Chang@mediatek.com>,
"Johnson Wang (王聖鑫)" <Johnson.Wang@mediatek.com>,
"Jason-ch Chen (陳建豪)" <Jason-ch.Chen@mediatek.com>,
"Shawn Sung (宋孝謙)" <Shawn.Sung@mediatek.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"Nancy Lin (林欣螢)" <Nancy.Lin@mediatek.com>,
"dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>,
Project_Global_Chrome_Upstream_Group
<Project_Global_Chrome_Upstream_Group@mediatek.com>,
"Nathan Lu (呂東霖)" <Nathan.Lu@mediatek.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>
Subject: Re: [PATCH v7 3/4] drm/mediatek: Add ability to support dynamic connector selection
Date: Mon, 31 Jul 2023 09:37:08 +0000 [thread overview]
Message-ID: <48a93b90740ec55ab8a563a5f0222a3a5c7d9673.camel@mediatek.com> (raw)
In-Reply-To: <7ba4f465-6910-8b23-e950-98598547e8d9@collabora.com>
Hi Angelo,
Thanks for the reviews.
On Fri, 2023-07-28 at 10:11 +0200, AngeloGioacchino Del Regno wrote:
> Il 27/07/23 18:41, Jason-JH.Lin ha scritto:
> > 1. Move output drm connector from each ddp_path array to connector
> > array.
> > 2. Add dynamic select available connector flow in crtc create and
> > enable.
> >
> > Signed-off-by: Nancy Lin <nancy.lin@mediatek.com>
> > Signed-off-by: Nathan Lu <nathan.lu@mediatek.com>
> > Signed-off-by: Jason-JH.Lin <jason-jh.lin@mediatek.com>
> > ---
> > drivers/gpu/drm/mediatek/mtk_disp_drv.h | 1 +
> > drivers/gpu/drm/mediatek/mtk_dpi.c | 9 +++
> > drivers/gpu/drm/mediatek/mtk_drm_crtc.c | 75
> > ++++++++++++++++++++-
> > drivers/gpu/drm/mediatek/mtk_drm_crtc.h | 5 +-
> > drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c | 26 +++++++
> > drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h | 8 +++
> > drivers/gpu/drm/mediatek/mtk_drm_drv.c | 20 ++++--
> > drivers/gpu/drm/mediatek/mtk_drm_drv.h | 7 ++
> > 8 files changed, 145 insertions(+), 6 deletions(-)
> >
>
> ..snip..
>
> > diff --git a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> > b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> > index f114da4d36a9..bc7b0a0c20db 100644
> > --- a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> > +++ b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> > @@ -304,6 +304,7 @@ static const struct mtk_ddp_comp_funcs
> > ddp_dither = {
> > static const struct mtk_ddp_comp_funcs ddp_dpi = {
> > .start = mtk_dpi_start,
> > .stop = mtk_dpi_stop,
> > + .encoder_index = mtk_dpi_encoder_index,
> > };
> >
> > static const struct mtk_ddp_comp_funcs ddp_dsc = {
> > @@ -507,6 +508,25 @@ static bool mtk_drm_find_comp_in_ddp(struct
> > device *dev,
> > return false;
> > }
> >
> > +static int mtk_drm_find_comp_in_ddp_conn_path(struct device *dev,
> > + const struct
> > mtk_drm_route *routes,
> > + unsigned int routes_num,
>
> `num_routes` would be more readable.
OK, I'll change this naming.
>
> > + struct mtk_ddp_comp
> > *ddp_comp)
> > +{
> > + unsigned int i;
> > +
> > + if (!routes)
> > + return 0;
>
> if (!routes)
> return -EINVAL;
OK, I'll change it.
>
> > +
> > + for (i = 0; i < routes_num; i++)
> > + if (dev == ddp_comp[routes[i].route_ddp].dev)
> > + return BIT(routes[i].crtc_id);
> > +
> > + DRM_INFO("Failed to find comp in ddp connector table\n");
>
> This print is redundant.
OK, I'll remove this print.
>
> > +
> > + return 0;
>
> return -ENODEV;
OK, I'll change it.
>
> > +}
> > +
> > int mtk_ddp_comp_get_id(struct device_node *node,
> > enum mtk_ddp_comp_type comp_type)
> > {
> > @@ -538,6 +558,12 @@ unsigned int
> > mtk_drm_find_possible_crtc_by_comp(struct drm_device *drm,
> > private->data->third_len,
> > private->ddp_comp))
> > ret = BIT(2);
> > else
> > + ret = mtk_drm_find_comp_in_ddp_conn_path(dev,
> > + private->data-
> > >conn_routes,
> > + private->data-
> > >num_conn_routes,
> > + private-
> > >ddp_comp);
> > +
> > + if (ret == 0)
>
> if (ret < 0)
>
> > DRM_INFO("Failed to find comp in ddp table\n");
The return value of mtk_drm_find_possible_crtc_by_comp() is `unsigned
int` and it will be assigned to `unsigned int ` dpi-
>encoder.possible_crtcs in mtk_dpi_bind() directly.
So we should reassign ret to 0 when ret < 0.
I would like to change to:
if (ret <= 0) {
DRM_INFO("Failed to find comp in ddp table, ret=%d\n", ret);
ret = 0;
}
Regards,
Jason-JH.Lin
> >
> > return ret;
>
> Regards,
> Angelo
>
>
>
>
next prev parent reply other threads:[~2023-07-31 9:37 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20230727164114.20638-1-jason-jh.lin@mediatek.com>
[not found] ` <20230727164114.20638-3-jason-jh.lin@mediatek.com>
2023-07-28 8:03 ` [PATCH v7 2/4] drm/mediatek: Fix using wrong drm private data to bind mediatek-drm CK Hu (胡俊光)
2023-07-28 8:11 ` AngeloGioacchino Del Regno
2023-07-28 8:47 ` Eugen Hristev
2023-07-31 8:21 ` Jason-JH Lin (林睿祥)
2023-07-31 8:32 ` Eugen Hristev
2023-08-02 7:05 ` Jason-JH Lin (林睿祥)
[not found] ` <20230727164114.20638-2-jason-jh.lin@mediatek.com>
2023-07-28 7:53 ` [PATCH v7 1/4] drm/mediatek: Add mmsys_dev_num to mt8188 vdosys0 driver data CK Hu (胡俊光)
2023-07-28 8:11 ` AngeloGioacchino Del Regno
[not found] ` <20230727164114.20638-5-jason-jh.lin@mediatek.com>
2023-07-28 8:14 ` [PATCH v7 4/4] drm/mediatek: Add DSI support for mt8188 vdosys0 AngeloGioacchino Del Regno
2023-07-31 16:08 ` Jason-JH Lin (林睿祥)
[not found] ` <20230727164114.20638-4-jason-jh.lin@mediatek.com>
2023-07-28 8:11 ` [PATCH v7 3/4] drm/mediatek: Add ability to support dynamic connector selection AngeloGioacchino Del Regno
2023-07-31 9:37 ` Jason-JH Lin (林睿祥) [this message]
2023-07-28 9:56 ` CK Hu (胡俊光)
2023-07-31 10:08 ` Jason-JH Lin (林睿祥)
2023-07-31 10:27 ` CK Hu (胡俊光)
2023-07-31 6:37 ` CK Hu (胡俊光)
2023-08-02 5:59 ` Jason-JH Lin (林睿祥)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=48a93b90740ec55ab8a563a5f0222a3a5c7d9673.camel@mediatek.com \
--to=jason-jh.lin@mediatek.com \
--cc=Jason-ch.Chen@mediatek.com \
--cc=Johnson.Wang@mediatek.com \
--cc=Nancy.Lin@mediatek.com \
--cc=Nathan.Lu@mediatek.com \
--cc=Project_Global_Chrome_Upstream_Group@mediatek.com \
--cc=Shawn.Sung@mediatek.com \
--cc=Singo.Chang@mediatek.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=chunkuang.hu@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®