From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751610AbcFSTny (ORCPT ); Sun, 19 Jun 2016 15:43:54 -0400 Received: from saturn.retrosnub.co.uk ([178.18.118.26]:39710 "EHLO saturn.retrosnub.co.uk" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751269AbcFSTmU (ORCPT ); Sun, 19 Jun 2016 15:42:20 -0400 Subject: Re: [RFC] regmap: Add regmap_pipe_read API To: Lars-Peter Clausen , Crestez Dan Leonard , Geert Uytterhoeven References: <7ca3857aa8869a1e1f4709860f57f7d92abf1c6b.1466089603.git.leonard.crestez@intel.com> <643b0e6a-49a0-00bb-7aed-6d36c1e0bb6b@intel.com> <5763AF5D.4090309@metafoo.de> Cc: Mark Brown , linux-spi , Wolfram Sang , Linux I2C , "linux-kernel@vger.kernel.org" From: Jonathan Cameron Message-ID: <495a344d-7d89-bee5-640d-a9ac78a49507@kernel.org> Date: Sun, 19 Jun 2016 20:40:05 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.1.0 MIME-Version: 1.0 In-Reply-To: <5763AF5D.4090309@metafoo.de> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 17/06/16 09:05, Lars-Peter Clausen wrote: > On 06/17/2016 09:04 AM, Crestez Dan Leonard wrote: >> On 06/16/2016 06:43 PM, Geert Uytterhoeven wrote: >>> Hi Leonard, >>> >>> On Thu, Jun 16, 2016 at 5:24 PM, Crestez Dan Leonard >>> wrote: >>>> The regmap API usually assumes that bulk read operations will read a >>>> range of registers but some I2C/SPI devices have certain registers for >>>> which a such a read operation will return data from an internal FIFO >>>> instead. Add an explicit API to support bulk read with pipe rather than >>>> range semantics. >>> >>> Please settle on either "fifo" or "pipe", instead of mixing both. >>> Personally, I prefer the former. >> >> Well, it doesn't have to be a fifo. The device can return data from some >> other kind of buffer (maybe a stack). I can adjust the documentation to >> clarify. >> >> I considered naming it something like regmap_multi_read_one_reg or >> something but regmap_pipe_read sounds reasonable and short. > > stream might be another option, but pipe is ok in my opinion. > I'm not fussy on naming, but definitely support having the functionality! Jonathan