Steven Rostedt wrote: > > On Wed, 14 Jan 2009, Gregory Haskins wrote: > > >> >> -#define enqueue_pushable_task(rq, p) do { } while (0) >> -#define dequeue_pushable_task(rq, p) do { } while (0) >> +static inline >> +void enqueue_pushable_task(struct rq *rq, struct task_struct *p) {} >> +static inline >> +void dequeue_pushable_task(struct rq *rq, struct task_struct *p) {} >> > > Wouldn't the above look better as: > > static inline void > enqueue_pushable_task(struct rq *rq, struct task_struct *p) > { > } > static inline void > dequeue_pushable_task(struct rq *rq, struct task_struct *p) > { > } > > I personally like to try to keep disabled functions ideally as close to one line as possible to visually denote that it isn't doing anything worth looking at. But I don't feel strongly either way, so whatever makes you guys happy. :) Shall I convert the others to this form as well? -Greg