From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-7.3 required=3.0 tests=BAYES_00,DKIMWL_WL_HIGH, DKIM_SIGNED,DKIM_VALID,DKIM_VALID_AU,HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,NICE_REPLY_A,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id F19A8C43460 for ; Fri, 23 Apr 2021 20:06:35 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id CF48D6144E for ; Fri, 23 Apr 2021 20:06:35 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S243904AbhDWUHL (ORCPT ); Fri, 23 Apr 2021 16:07:11 -0400 Received: from us-smtp-delivery-124.mimecast.com ([170.10.133.124]:37767 "EHLO us-smtp-delivery-124.mimecast.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S231721AbhDWUHI (ORCPT ); Fri, 23 Apr 2021 16:07:08 -0400 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=redhat.com; s=mimecast20190719; t=1619208390; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding: in-reply-to:in-reply-to:references:references; bh=4QiJOyaRBjpj+Qp4w+e7694mCmNFhGls/eL4ztohU9Y=; b=KgF5KQpWtQ/LCHQk6CqWB1RD/xvN4tDzE2C499dTMecYMM/XXp1yq1dow3HPTAMoLKWwqO A6ganN8cKc525c8t+6rv7F5BWTJiEeFv1lofxVqNe3Pl/mYdo2fYaZAsWN9GEHdFc9/JpK uH7L98dlX9mElc7DmcFsprs8WCkdp2A= Received: from mail-qv1-f70.google.com (mail-qv1-f70.google.com [209.85.219.70]) (Using TLS) by relay.mimecast.com with ESMTP id us-mta-400-mvX0ehGNM9WD-GtB4TxBKA-1; Fri, 23 Apr 2021 16:06:29 -0400 X-MC-Unique: mvX0ehGNM9WD-GtB4TxBKA-1 Received: by mail-qv1-f70.google.com with SMTP id a15-20020a0cca8f0000b029019d6ca62771so19077458qvk.4 for ; Fri, 23 Apr 2021 13:06:28 -0700 (PDT) X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:subject:to:cc:references:message-id:date :user-agent:mime-version:in-reply-to:content-transfer-encoding :content-language; bh=4QiJOyaRBjpj+Qp4w+e7694mCmNFhGls/eL4ztohU9Y=; b=Z7OCuK2g4jJVxUxhyqrJl39p1EarRXNAlV9CxKPLknyk6pCCnKUeCTNUn2uplRpueU BzFVo+qRbXJMsaZJnc5fyoif2Lr24YR3eEdhpvOuiufJcjl1wQFeGfOQKgM5Apa6CBEw wLl11DUPWtmbftLn1jM2aII5I9iIrjcfKZm+70U3P2msMRoyw+plK+FFYMgZ1BlhW5oX +Swj0oZvuU1LyzRwp2I51FYjLTHJCbutnpFdubl34+HzWIMr9XAZqDgPd2jtxnDLAlvv EsDW0rZy/4XXTPsAHx4SIqJLvII3usBpfEJ3SmdcdYIm802Qy8bh9wTrn+WlOmAYvYcL Iv4w== X-Gm-Message-State: AOAM5334xOp4gv102HkxLsfLykbSpnJ72ZYS4zVP2mutwaZUCLHlMc7n 5oL94i0ag+HN/vGpwUjHIpcufGX+USzjUD/LrOYsBD6eZJwuds9pH8OfUvNP8VDs/ia+9AU+104 ccKVZLROTqK1JzQvOCyYcF7pT X-Received: by 2002:a0c:f04a:: with SMTP id b10mr6261764qvl.59.1619208388190; Fri, 23 Apr 2021 13:06:28 -0700 (PDT) X-Google-Smtp-Source: ABdhPJzgdtumIs7B0CTazXqadnVbV5Zu/bStO7szazOP/9Tj1DQ93qT3QIMbESYDUlPfIwa3ilxYSg== X-Received: by 2002:a0c:f04a:: with SMTP id b10mr6261738qvl.59.1619208387658; Fri, 23 Apr 2021 13:06:27 -0700 (PDT) Received: from llong.remote.csb ([2601:191:8500:76c0::cdbc]) by smtp.gmail.com with ESMTPSA id f2sm5109329qkh.76.2021.04.23.13.06.26 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Fri, 23 Apr 2021 13:06:27 -0700 (PDT) From: Waiman Long X-Google-Original-From: Waiman Long Subject: Re: [PATCH-next v5 3/4] mm/memcg: Improve refill_obj_stock() performance To: Roman Gushchin , Waiman Long Cc: Johannes Weiner , Michal Hocko , Vladimir Davydov , Andrew Morton , Tejun Heo , Christoph Lameter , Pekka Enberg , David Rientjes , Joonsoo Kim , Vlastimil Babka , linux-kernel@vger.kernel.org, cgroups@vger.kernel.org, linux-mm@kvack.org, Shakeel Butt , Muchun Song , Alex Shi , Chris Down , Yafang Shao , Wei Yang , Masayoshi Mizuma , Xing Zhengjun , Matthew Wilcox References: <20210420192907.30880-1-longman@redhat.com> <20210420192907.30880-4-longman@redhat.com> Message-ID: <49715eb2-9ac4-8208-2c63-e432092c3ab2@redhat.com> Date: Fri, 23 Apr 2021 16:06:25 -0400 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.9.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Content-Language: en-US Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 4/22/21 10:28 PM, Roman Gushchin wrote: > On Thu, Apr 22, 2021 at 01:26:08PM -0400, Waiman Long wrote: >> On 4/21/21 7:55 PM, Roman Gushchin wrote: >>> On Tue, Apr 20, 2021 at 03:29:06PM -0400, Waiman Long wrote: >>>> There are two issues with the current refill_obj_stock() code. First of >>>> all, when nr_bytes reaches over PAGE_SIZE, it calls drain_obj_stock() to >>>> atomically flush out remaining bytes to obj_cgroup, clear cached_objcg >>>> and do a obj_cgroup_put(). It is likely that the same obj_cgroup will >>>> be used again which leads to another call to drain_obj_stock() and >>>> obj_cgroup_get() as well as atomically retrieve the available byte from >>>> obj_cgroup. That is costly. Instead, we should just uncharge the excess >>>> pages, reduce the stock bytes and be done with it. The drain_obj_stock() >>>> function should only be called when obj_cgroup changes. >>> I really like this idea! Thanks! >>> >>> However, I wonder if it can implemented simpler by splitting drain_obj_stock() >>> into two functions: >>> empty_obj_stock() will flush cached bytes, but not reset the objcg >>> drain_obj_stock() will call empty_obj_stock() and then reset objcg >>> >>> Then we simple can replace the second drain_obj_stock() in >>> refill_obj_stock() with empty_obj_stock(). What do you think? >> Actually the problem is the flushing cached bytes to objcg->nr_charged_bytes >> that can become a performance bottleneck in a multithreaded testing >> scenario. See my description in the latter half of my cover-letter. >> >> For cgroup v2, update the page charge will mostly update the per-cpu page >> charge stock. Flushing the remaining byte charge, however, will cause the >> obgcg to became the single contended cacheline for all the cpus that need to >> flush the byte charge. That is why I only update the page charge and left >> the remaining byte charge stayed put in the object stock. >> >>>> Secondly, when charging an object of size not less than a page in >>>> obj_cgroup_charge(), it is possible that the remaining bytes to be >>>> refilled to the stock will overflow a page and cause refill_obj_stock() >>>> to uncharge 1 page. To avoid the additional uncharge in this case, >>>> a new overfill flag is added to refill_obj_stock() which will be set >>>> when called from obj_cgroup_charge(). >>>> >>>> A multithreaded kmalloc+kfree microbenchmark on a 2-socket 48-core >>>> 96-thread x86-64 system with 96 testing threads were run. Before this >>>> patch, the total number of kilo kmalloc+kfree operations done for a 4k >>>> large object by all the testing threads per second were 4,304 kops/s >>>> (cgroup v1) and 8,478 kops/s (cgroup v2). After applying this patch, the >>>> number were 4,731 (cgroup v1) and 418,142 (cgroup v2) respectively. This >>>> represents a performance improvement of 1.10X (cgroup v1) and 49.3X >>>> (cgroup v2). >>> This part looks more controversial. Basically if there are N consequent >>> allocations of size (PAGE_SIZE + x), the stock will end up with (N * x) >>> cached bytes, right? It's not the end of the world, but do we really >>> need it given that uncharging a page is also cached? >> Actually the maximum charge that can be accumulated in (2*PAGE_SIZE + x - 1) >> since a following consume_obj_stock() will use those bytes once the byte >> charge is not less than (PAGE_SIZE + x). > Got it, thank you for the explanation! > > Can you, please, add a comment explaining what the "overfill" parameter does > and why it has different values on charge and uncharge paths? > Personally, I'd revert it's meaning and rename it to something like "trim" > or just plain "bool charge". > I think the simple explanation is that during the charge we can't refill more > than a PAGE_SIZE - 1 and the following allocation will likely use it or > the following deallocation will trim it if necessarily. > And on the uncharge path there are no bounds and the following deallocation > can only increase the cached value. Yes, that is the intention. I will make suggested change and put in a comment about it. Thanks, Longman