mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Jan Beulich" <jbeulich@novell.com>
To: "Ingo Molnar" <mingo@elte.hu>
Cc: "Alexander van Heukelum" <heukelum@fastmail.fm>,
	"Andi Kleen" <andi@firstfloor.org>,
	"Cyrill Gorcunov" <gorcunov@gmail.com>, <tglx@linutronix.de>,
	<linux-kernel@vger.kernel.org>, <hpa@zytor.com>
Subject: Re: [PATCH] x86-64: add unwind annotations to early_idt_handler
Date: Thu, 12 Mar 2009 11:36:01 +0000	[thread overview]
Message-ID: <49B901B1.76E4.0078.0@novell.com> (raw)
In-Reply-To: <20090312105345.GB30204@elte.hu>

>>> Ingo Molnar <mingo@elte.hu> 12.03.09 11:53 >>>
>* Jan Beulich <jbeulich@novell.com> wrote:
>> @@ -295,6 +297,16 @@ ENTRY(early_idt_handler)
>>  	testl $0x27d00,%eax
>>  	je 0f
>>  	popq %r8		# get error code
>> +
>> +	CFI_STARTPROC	simple
>> +	CFI_SIGNAL_FRAME
>> +	CFI_DEF_CFA	rsp, SS+8-RIP
>> +#	CFI_REL_OFFSET	ss, SS-RIP
>> +	CFI_REL_OFFSET	rsp, RSP-RIP
>> +#	CFI_REL_OFFSET	rflags, EFLAGS-RIP
>> +#	CFI_REL_OFFSET	cs, CS-RIP
>> +	CFI_REL_OFFSET	rip, RIP-RIP
>> +
>
>This too is too ugly - there should be a structured macro that 
>expresses this - instead of open-coded CFI details. This is a 
>regular x86 entry layout with a lot of commonalities with other 
>entry points.

I can certainly do that, but it'll introduce yet another patch
dependency (with the patch fixing the entry_64.S annotations), as it
would mean moving out some of the macros from entry_64.S to one
of the headers. That means I'll first have to get clarification on where
you want to go with these annotations altogether.

Jan


      reply	other threads:[~2009-03-12 11:35 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-03-12 10:36 Jan Beulich
2009-03-12 10:53 ` Ingo Molnar
2009-03-12 11:36   ` Jan Beulich [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=49B901B1.76E4.0078.0@novell.com \
    --to=jbeulich@novell.com \
    --cc=andi@firstfloor.org \
    --cc=gorcunov@gmail.com \
    --cc=heukelum@fastmail.fm \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®