From: Jeremy Fitzhardinge <jeremy@goop.org>
To: Sheng Yang <sheng@linux.intel.com>
Cc: Keir Fraser <keir.fraser@eu.citrix.com>,
Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>,
Ian Pratt <Ian.Pratt@eu.citrix.com>,
xen-devel <xen-devel@lists.xensource.com>,
Ian Campbell <Ian.Campbell@citrix.com>,
Stefano Stabellini <stefano.stabellini@eu.citrix.com>,
"Yaozu (Eddie) Dong" <eddie.dong@intel.com>,
linux-kernel@vger.kernel.org
Subject: Re: [Xen-devel] [PATCH 3/7] xen/hvm: Xen PV extension of HVM initialization
Date: Mon, 01 Mar 2010 17:43:37 -0800 [thread overview]
Message-ID: <4B8C6D49.6000606@goop.org> (raw)
In-Reply-To: <201003020938.53630.sheng@linux.intel.com>
On 03/01/2010 05:38 PM, Sheng Yang wrote:
>> Why use this? Why not just set the domain type to HVM, and leave the
>> "status" field as a bitset of available paravirtualizations?
>>
> A annoy thing in pv drivers is that it would test if the domain type is _NOT_
> XEN_NATIVE. So set the domain to XEN_HVM_DOMAIN would result in PV driver
> initialization then probably panic. Maybe we can do something to PV drivers,
> as patch 6 and a part of patch 7.
>
In that case, change them to specifically test for PV until they're
ready to deal with an HVM environment.
>
> Part of pv_ops are overlapped. I would try if a new file would bring much
> duplicate.
>
It shouldn't do; un-static things if necessary.
>>> + .align PAGE_SIZE_asm
>>> +ENTRY(shared_info_page)
>>> + .skip PAGE_SIZE_asm
>>> +.popsection
>>>
>> Why does this need to be defined in asm? Can't it be either allocated
>> or defined in C?
>>
> I think we need a aligned page, as hypercall page.
>
That can be declared in C with the __page_aligned_bss annotation. And
couldn't you dynamically allocate it with the bootmem allocator?
>> I think "status" is a misnomer here. Isn't it specifically a set of PV
>> features which are active?
>>
> Could you give a suggestion of the name? I am not a native English speaker...
>
xen_hvm_pv_features.
J
next prev parent reply other threads:[~2010-03-02 1:43 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-03-01 9:38 [PATCH 0/7][v4] PV extension of HVM (Hybrid) for Xen Sheng Yang
2010-03-01 9:38 ` [PATCH 1/7] xen: add support for hvm_op Sheng Yang
2010-03-01 9:38 ` [PATCH 2/7] xen: Import cpuid.h from Xen Sheng Yang
2010-03-01 9:38 ` [PATCH 3/7] xen/hvm: Xen PV extension of HVM initialization Sheng Yang
2010-03-02 1:02 ` [Xen-devel] " Jeremy Fitzhardinge
2010-03-02 1:38 ` Sheng Yang
2010-03-02 1:43 ` Jeremy Fitzhardinge [this message]
2010-03-02 9:22 ` Ian Campbell
2010-03-02 20:17 ` Jeremy Fitzhardinge
2010-03-03 11:35 ` Stefano Stabellini
2010-03-03 17:35 ` Jeremy Fitzhardinge
2010-03-03 17:41 ` Stefano Stabellini
2010-03-04 10:18 ` Ian Campbell
2010-03-01 9:38 ` [PATCH 4/7] xen: The entrance for PV extension of HVM Sheng Yang
2010-03-02 1:05 ` [Xen-devel] " Jeremy Fitzhardinge
2010-03-02 1:41 ` Sheng Yang
2010-03-01 9:38 ` [PATCH 5/7] xen: Make event channel work with " Sheng Yang
2010-03-02 1:38 ` [Xen-devel] " Jeremy Fitzhardinge
2010-03-02 5:48 ` Sheng Yang
2010-03-03 18:31 ` Jeremy Fitzhardinge
2010-03-04 5:37 ` Sheng Yang
2010-03-04 11:58 ` Stefano Stabellini
2010-03-08 22:31 ` Jeremy Fitzhardinge
2010-03-01 9:38 ` [PATCH 6/7] xen: Unified checking for Xen of PV drivers to xenbus_register_frontend() Sheng Yang
2010-03-02 1:45 ` [Xen-devel] " Jeremy Fitzhardinge
2010-03-01 9:38 ` [PATCH 7/7] xen: Enable grant table and xenbus for PV extension of HVM Sheng Yang
2010-03-01 17:38 ` [LKML] " Konrad Rzeszutek Wilk
2010-03-02 1:13 ` Sheng Yang
2010-03-02 1:21 ` Sheng Yang
2010-03-02 13:41 ` Konrad Rzeszutek Wilk
2010-03-02 14:09 ` Ian Campbell
2010-03-02 0:42 ` [Xen-devel] [PATCH 0/7][v4] PV extension of HVM (Hybrid) for Xen Jeremy Fitzhardinge
2010-03-02 1:26 ` Sheng Yang
2010-03-02 1:32 ` Jeremy Fitzhardinge
2010-03-02 1:34 ` Sheng Yang
2010-03-02 3:20 ` Dong, Eddie
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4B8C6D49.6000606@goop.org \
--to=jeremy@goop.org \
--cc=Ian.Campbell@citrix.com \
--cc=Ian.Pratt@eu.citrix.com \
--cc=eddie.dong@intel.com \
--cc=jeremy.fitzhardinge@citrix.com \
--cc=keir.fraser@eu.citrix.com \
--cc=linux-kernel@vger.kernel.org \
--cc=sheng@linux.intel.com \
--cc=stefano.stabellini@eu.citrix.com \
--cc=xen-devel@lists.xensource.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome