mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Arjan van de Ven <arjan@linux.intel.com>
To: Yong Zhang <yong.zhang0@gmail.com>
Cc: linux-kernel@vger.kernel.org, tglx@linutronix.de,
	akpm@linux-foundation.org, mingo@elte.hu, a.p.zijlstra@chello.nl,
	tj@kernel.org, oleg@redhat.com
Subject: Re: [RFC PATCHSET 0/6] timer/hrtimer/timer_stats: Improvement on timer_stats
Date: Sun, 29 Aug 2010 08:44:45 -0700	[thread overview]
Message-ID: <4C7A806D.4010106@linux.intel.com> (raw)
In-Reply-To: <1283094309-6635-1-git-send-email-yong.zhang0@gmail.com>

On 8/29/2010 8:05 AM, Yong Zhang wrote:
> Hi,
>
> This patchset focus on two problem:
>
> 1)timer_stats_timer_*_start_info() should belong to timer core only.
>    It should not be seen by outsider, such as workqueue. And should
>    not resident in timer.h.
>    Patch-0001~0003 first remove the only explicit out call, then move
>    timer_stats_timer_*_start_info() from timer.h to timer.c.
>
> 2)call site recorded by timer_stats sometimes show the timer core functions
>    instead of the real call site.
>    Now /proc/timer_stats is like below on my machine:
> ---now---
>    


one question; have you tested this with powertop? (powertop being one of 
the prime consumers of this interface)


  parent reply	other threads:[~2010-08-29 15:44 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-29 15:05 Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 1/6] timer: expliciyly call timer_stats_timer_set_start_info() in add_timer() Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 2/6] workqueue: remove redundant timer_stats_timer_set_start_info() Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 3/6] timer: move timer_stats_timer_*_start_info() to kernel/timer.c Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 4/6] hrtimer: change call site of timer_stats_hrtimer_clear_start_info() Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 5/6] hrtimer: record more real start_site for timer_stats Yong Zhang
2010-08-29 15:05 ` [RFC PATCH 6/6] timer_stats: make output more readable Yong Zhang
2010-08-29 15:44 ` Arjan van de Ven [this message]
2010-08-30  3:27   ` [RFC PATCHSET 0/6] timer/hrtimer/timer_stats: Improvement on timer_stats Yong Zhang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4C7A806D.4010106@linux.intel.com \
    --to=arjan@linux.intel.com \
    --cc=a.p.zijlstra@chello.nl \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=oleg@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=tj@kernel.org \
    --cc=yong.zhang0@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome