From: Kumar Gala <galak@kernel.crashing.org>
To: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Cc: jeremy@goop.org, hch@infradead.org, linux-kernel@vger.kernel.org,
mingo@elte.hu, ian.campbell@citrix.com,
beckyb@kernel.crashing.org
Subject: Re: [PATCH 4/7] swiotlb: Allow arch override of address_needs_mapping
Date: Wed, 8 Apr 2009 23:59:18 -0500 [thread overview]
Message-ID: <4D1571C8-53B8-4A4E-BCE8-7267ED262189@kernel.crashing.org> (raw)
In-Reply-To: <20090409080143C.fujita.tomonori@lab.ntt.co.jp>
On Apr 8, 2009, at 6:01 PM, FUJITA Tomonori wrote:
>> Becky's patches of last week also added __weak annotations to
>> swiotlb_bus_to_virt, virt_to_bus and bus_to_phys; added the hwdev
>> parameter to swiotlb_bus_to_phys; and added a weak
>> swiotlb_arch_address_needs_mapping. I assume that was needed because
>> powerpc needs non-trivial implementations for those functions.
>
> Hmm, what she added are wrappers of virt_to_bus and bus_to_virt. We
> can remove these and directly use virt_to_bus and bus_to_virt.
>
> About __weak address_needs_mapping function, as I said, removing it
> and using dma_map_ops is a proper solution.
Is this something you are looking at doing in the .31 timeframe?
I'm looking at the fact that we need to switch over to using struct
dma_map_ops on ppc. (I'm guessing this might be the patches you
mentioned the other day). If so did you add set_dma_mask() to the
generic dma_map_ops?
- k
next prev parent reply other threads:[~2009-04-09 5:01 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-08 14:09 [PATCH V3 0/7] swiotlb: changes for powerpc/highmem Kumar Gala
2009-04-08 14:09 ` [PATCH 1/7] swiotlb: comment corrections (no code changes) Kumar Gala
2009-04-08 14:09 ` [PATCH 2/7] swiotlb: fix compile warning Kumar Gala
2009-04-08 14:09 ` [PATCH 3/7] swiotlb: map_page fix for highmem systems Kumar Gala
2009-04-08 14:09 ` [PATCH 4/7] swiotlb: Allow arch override of address_needs_mapping Kumar Gala
2009-04-08 14:09 ` [PATCH 5/7] swiotlb: Rename unmap_single to do_unmap_single Kumar Gala
2009-04-08 14:09 ` [PATCH 6/7] swiotlb: Use swiotlb_sync_single instead of duplicating code Kumar Gala
2009-04-08 14:09 ` [PATCH 7/7] swiotlb: Change swiotlb_bus_to[phys,virt] prototypes Kumar Gala
2009-04-08 15:25 ` [tip:core/iommu] swiotlb: change " Becky Bruce
2009-04-08 15:25 ` [tip:core/iommu] swiotlb: use swiotlb_sync_single instead of duplicating code Becky Bruce
2009-04-08 15:25 ` [tip:core/iommu] swiotlb: rename unmap_single to do_unmap_single Becky Bruce
2009-04-08 15:25 ` [tip:core/iommu] swiotlb: allow arch override of address_needs_mapping Becky Bruce
2009-04-08 20:38 ` [PATCH 4/7] swiotlb: Allow " Christoph Hellwig
2009-04-08 20:56 ` Kumar Gala
2009-04-08 21:15 ` FUJITA Tomonori
2009-04-08 21:55 ` Jeremy Fitzhardinge
2009-04-08 22:10 ` FUJITA Tomonori
2009-04-08 22:36 ` Jeremy Fitzhardinge
2009-04-08 23:01 ` FUJITA Tomonori
2009-04-08 23:16 ` Jeremy Fitzhardinge
2009-04-08 23:37 ` FUJITA Tomonori
2009-04-09 0:09 ` Jeremy Fitzhardinge
2009-04-09 4:43 ` Kumar Gala
2009-04-09 18:34 ` FUJITA Tomonori
2009-04-09 19:19 ` Jeremy Fitzhardinge
2009-04-09 19:43 ` FUJITA Tomonori
2009-04-09 19:50 ` FUJITA Tomonori
2009-04-09 19:54 ` Jeremy Fitzhardinge
2009-04-09 4:59 ` Kumar Gala [this message]
2009-04-09 18:50 ` FUJITA Tomonori
2009-04-09 20:10 ` Kumar Gala
2009-04-09 20:25 ` Kumar Gala
2009-04-08 22:24 ` Christoph Hellwig
2009-04-08 15:24 ` [tip:core/iommu] swiotlb: map_page fix for highmem systems Becky Bruce
2009-04-08 15:24 ` [tip:core/iommu] swiotlb: fix compile warning Becky Bruce
2009-04-08 15:24 ` [tip:core/iommu] swiotlb: comment corrections Becky Bruce
2009-04-08 14:21 ` [PATCH V3 0/7] swiotlb: changes for powerpc/highmem Ingo Molnar
-- strict thread matches above, loose matches on Subject: below --
2009-04-04 1:56 [PATCH V2 " Becky Bruce
2009-04-04 1:56 ` [PATCH 1/7] swiotlb: comment corrections (no code changes) Becky Bruce
2009-04-04 1:56 ` [PATCH 2/7] swiotlb: fix compile warning Becky Bruce
2009-04-04 1:56 ` [PATCH 3/7] swiotlb: map_page fix for highmem systems Becky Bruce
2009-04-04 1:56 ` [PATCH 4/7] swiotlb: Allow arch override of address_needs_mapping Becky Bruce
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4D1571C8-53B8-4A4E-BCE8-7267ED262189@kernel.crashing.org \
--to=galak@kernel.crashing.org \
--cc=beckyb@kernel.crashing.org \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=hch@infradead.org \
--cc=ian.campbell@citrix.com \
--cc=jeremy@goop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®