mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Oren Laadan <orenl@cs.columbia.edu>
To: Serge Hallyn <serge.hallyn@canonical.com>
Cc: Bastian Blank <bastian@waldi.eu.org>,
	"Serge E. Hallyn" <serge@hallyn.com>,
	containers@lists.linux-foundation.org,
	kernel list <linux-kernel@vger.kernel.org>,
	LSM <linux-security-module@vger.kernel.org>,
	"Eric W. Biederman" <ebiederm@xmission.com>,
	Kees Cook <kees.cook@canonical.com>,
	Alexey Dobriyan <adobriyan@gmail.com>,
	Michael Kerrisk <mtk.manpages@gmail.com>
Subject: Re: [PATCH 4/7] allow killing tasks in your own or child userns
Date: Mon, 10 Jan 2011 23:22:12 -0500	[thread overview]
Message-ID: <4D2BDAF4.9040908@cs.columbia.edu> (raw)
In-Reply-To: <20110110225151.GA18944@localhost>



On 01/10/2011 05:51 PM, Serge Hallyn wrote:
> Quoting Bastian Blank (bastian@waldi.eu.org):
>> On Mon, Jan 10, 2011 at 09:13:34PM +0000, Serge E. Hallyn wrote:
>>> +	const struct cred *cred = current_cred();
>>> +	const struct cred *tcred = __task_cred(t);
>>> +
>>> +	if (cred->user->user_ns != tcred->user->user_ns) {
>>> +		/* userids are not equivalent - either you have the
>>> +		   capability to the target user ns or you don't */
>>> +		if (ns_capable(tcred->user->user_ns, CAP_KILL))
>>> +			return 1;
>>> +		return 0;
>>> +	}
>>> +
>>> +	/* same user namespace - usual credentials checks apply */
>>> +	if ((cred->euid ^ tcred->suid) &&
>>> +	    (cred->euid ^ tcred->uid) &&
>>> +	    (cred->uid  ^ tcred->suid) &&
>>> +	    (cred->uid  ^ tcred->uid) &&
>>> +	    !ns_capable(tcred->user->user_ns, CAP_KILL))
>>> +		return 0;
>>> +
>>> +	return 1;
>>
>> Isn't that equal to this?
>>
>> 	if (ns_capable(tcred->user->user_ns, CAP_KILL))
>> 		return 1;
>>
>> 	if (cred->user->user_ns == tcred->user->user_ns &&
>> 	    (cred->euid == tcred->suid ||
>> 	     cred->euid == tcred->uid ||
>> 	     cred->uid == tcred->suid ||
>> 	     cred->uid == tcred->uid))
>> 		return 1;
>>
>> 	return 0;
>>
>> I would consider this much easier to read.
> 
> Unfortunately, it's actually not equivalent.  when capable()
> returns success, then it sets the current->flags |= PF_SUPERPRIV.
> If permission is granted based on userids and the capability
> isn't needed, then we don't want to needlessly set PF_SUPERPRIV.

A bit off-topic: does this means that c/r needs to save and 
restore this process flag ?
> 
> That's why I'm going to such lengths to call capable() as a last
> resort.

IMHO, worth a one line comment in the code ...

Oren.

  parent reply	other threads:[~2011-01-11  4:49 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-01-10 21:11 userns: targeted capabilities v3 Serge E. Hallyn
2011-01-10 21:13 ` [PATCH 1/7] Add a user_namespace as creator/owner of uts_namespace Serge E. Hallyn
2011-01-10 21:13 ` [PATCH 2/7] security: Make capabilities relative to the user namespace Serge E. Hallyn
2011-01-10 21:13 ` [PATCH 3/7] allow sethostname in a container Serge E. Hallyn
2011-01-10 21:13 ` [PATCH 4/7] allow killing tasks in your own or child userns Serge E. Hallyn
2011-01-10 21:52   ` Bastian Blank
2011-01-10 22:51     ` Serge Hallyn
2011-01-10 23:23       ` Bastian Blank
2011-01-11  1:31         ` Serge E. Hallyn
2011-01-14 14:50           ` Bastian Blank
2011-01-15  0:31             ` Serge E. Hallyn
2011-01-15 11:30               ` Bastian Blank
2011-01-15 14:12                 ` Serge E. Hallyn
2011-01-11  4:22       ` Oren Laadan [this message]
2011-01-11  4:32         ` Serge E. Hallyn
2011-01-10 21:13 ` [PATCH 5/7] Allow ptrace from non-init user namespaces Serge E. Hallyn
2011-01-10 21:14 ` [PATCH 6/7] user namespaces: convert all capable checks in kernel/sys.c Serge E. Hallyn
2011-01-10 21:59   ` Bastian Blank
2011-01-10 22:56     ` Serge Hallyn
2011-01-11  5:27     ` Serge E. Hallyn
2011-01-14 15:02       ` Bastian Blank
2011-01-10 21:14 ` [PATCH 7/7] user namespaces: convert several capable() calls Serge E. Hallyn

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4D2BDAF4.9040908@cs.columbia.edu \
    --to=orenl@cs.columbia.edu \
    --cc=adobriyan@gmail.com \
    --cc=bastian@waldi.eu.org \
    --cc=containers@lists.linux-foundation.org \
    --cc=ebiederm@xmission.com \
    --cc=kees.cook@canonical.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=mtk.manpages@gmail.com \
    --cc=serge.hallyn@canonical.com \
    --cc=serge@hallyn.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®