From: "Jan Beulich" <JBeulich@novell.com>
To: "Ingo Molnar" <mingo@elte.hu>
Cc: <tony.luck@intel.com>, <tglx@linutronix.de>,
<akpm@linux-foundation.org>, <linux-kernel@vger.kernel.org>,
<hpa@zytor.com>
Subject: Re: [PATCH 2/3] x86-64: use relative 32-bit pointers in exception tables
Date: Fri, 18 Feb 2011 08:07:41 +0000 [thread overview]
Message-ID: <4D5E36DD02000078000329CE@vpn.id2.novell.com> (raw)
In-Reply-To: <20110217172559.GD17058@elte.hu>
>>> On 17.02.11 at 18:25, Ingo Molnar <mingo@elte.hu> wrote:
> Nice patch. I've got a really small code readability nitpick:
>
>> +#ifndef ex_insn /* until all architectures have this accessor */
>> +#define ex_insn(x) (x)->insn
>> +#endif
>
>> +#else
>> +#define swap_ex NULL
>> +#endif
>
> In the x86 architecture we tend to write this as:
>
>> +#else
>> +# define swap_ex NULL
>> +#endif
>
> So that the conditional structure stands out more, visually. (There might be
> more
> such cases in these patches as well.)
I can certainly fix this, but got a comment from (I think) Andrew
Morton to do exactly the opposite quite some time ago, with the
rationale that this indentation leads to more involved patches
when further conditionals get added around them.
As I'll have to fix the test_nx issue hpa pointed out anyway, I can
adjust this as you say, but I'd prefer you to confirm first whether
indeed you think this is the right thing to do in non-x86 code.
Jan
next prev parent reply other threads:[~2011-02-18 8:06 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-02-17 17:03 Jan Beulich
2011-02-17 17:25 ` Ingo Molnar
2011-02-18 8:07 ` Jan Beulich [this message]
2011-02-18 8:14 ` Ingo Molnar
2011-02-18 4:49 ` H. Peter Anvin
2011-02-18 9:34 ` Jan Beulich
2011-02-18 10:32 ` Jan Beulich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4D5E36DD02000078000329CE@vpn.id2.novell.com \
--to=jbeulich@novell.com \
--cc=akpm@linux-foundation.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®