On 04/27/2011 03:08 PM, Subhasish Ghosh wrote: >>>> +static u32 pruss_intc_init[19][3] = { >>>> + {PRUSS_INTC_POLARITY0, PRU_INTC_REGMAP_MASK, 0xFFFFFFFF}, >>>> + {PRUSS_INTC_POLARITY1, PRU_INTC_REGMAP_MASK, 0xFFFFFFFF}, >>>> + {PRUSS_INTC_TYPE0, PRU_INTC_REGMAP_MASK, 0x1C000000}, >>>> + {PRUSS_INTC_TYPE1, PRU_INTC_REGMAP_MASK, 0}, >>>> + {PRUSS_INTC_GLBLEN, 0, 1}, >>>> + {PRUSS_INTC_HOSTMAP0, PRU_INTC_REGMAP_MASK, 0x03020100}, >>>> + {PRUSS_INTC_HOSTMAP1, PRU_INTC_REGMAP_MASK, 0x07060504}, >>>> + {PRUSS_INTC_HOSTMAP2, PRU_INTC_REGMAP_MASK, 0x0000908}, >>>> + {PRUSS_INTC_CHANMAP0, PRU_INTC_REGMAP_MASK, 0}, >>>> + {PRUSS_INTC_CHANMAP8, PRU_INTC_REGMAP_MASK, 0x00020200}, >>>> + {PRUSS_INTC_STATIDXCLR, 0, 32}, >>>> + {PRUSS_INTC_STATIDXCLR, 0, 19}, >>>> + {PRUSS_INTC_ENIDXSET, 0, 19}, >>>> + {PRUSS_INTC_STATIDXCLR, 0, 18}, >>>> + {PRUSS_INTC_ENIDXSET, 0, 18}, >>>> + {PRUSS_INTC_STATIDXCLR, 0, 34}, >>>> + {PRUSS_INTC_ENIDXSET, 0, 34}, >>>> + {PRUSS_INTC_ENIDXSET, 0, 32}, >>>> + {PRUSS_INTC_HOSTINTEN, 0, 5} >>> >>> please add "," >> >> Also a struct to describe each entry would improve readability. >> Then you could also use ARRAY_SIZE. > > SG _ I could not follow this, are you recommending that I create a > structure with three variables and then create > an array for it. > something like: > > const static struct [] = { > { > unsigned int reg_base; > unsigned int reg_mask; > unsigned int reg_val; > }, > ... > }; I think this isn't valid C. It should look like this: struct pruss_intc_init { unsigned long reg_base; u32 reg_mask; u32 reg+val; }; static const struct pruss_intc_init pruss_initc_init[] = { { .reg_base = 0xdeadbeef, .reg_mask = 0xaa, .reg_val = 0x55 }, ... }; I'm not sure about the datatype of reg_base. I haven't looked at the code that uses this array. cheers, Marc -- Pengutronix e.K. | Marc Kleine-Budde | Industrial Linux Solutions | Phone: +49-231-2826-924 | Vertretung West/Dortmund | Fax: +49-5121-206917-5555 | Amtsgericht Hildesheim, HRA 2686 | http://www.pengutronix.de |