mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marek Vasut <marex@denx.de>
To: Luca Ceresoli <luca.ceresoli@bootlin.com>
Cc: dri-devel@lists.freedesktop.org,
	Andrzej Hajda <andrzej.hajda@intel.com>,
	Neil Armstrong <neil.armstrong@linaro.org>,
	Robert Foss <rfoss@kernel.org>,
	Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
	Jonas Karlman <jonas@kwiboo.se>,
	Jernej Skrabec <jernej.skrabec@gmail.com>,
	David Airlie <airlied@gmail.com>, Daniel Vetter <daniel@ffwll.ch>,
	linux-kernel@vger.kernel.org,
	Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
	Paul Kocialkowski <paul.kocialkowski@bootlin.com>
Subject: Re: [PATCH] drm: bridge: ldb: add support for using channel 1 only
Date: Wed, 5 Apr 2023 14:31:31 +0200	[thread overview]
Message-ID: <4b15b282-7243-3f75-4a2e-ba86791f6431@denx.de> (raw)
In-Reply-To: <20230405093017.62ccb4f6@booty>

On 4/5/23 09:30, Luca Ceresoli wrote:

[...]

>>> @@ -311,10 +314,23 @@ static int fsl_ldb_probe(struct platform_device *pdev)
>>>    	if (IS_ERR(fsl_ldb->regmap))
>>>    		return PTR_ERR(fsl_ldb->regmap);
>>>    
>>> -	/* Locate the panel DT node. */
>>> -	panel_node = of_graph_get_remote_node(dev->of_node, 1, 0);
>>> -	if (!panel_node)
>>> -		return -ENXIO;
>>> +	/* Locate the remote ports and the panel node */
>>> +	remote1 = of_graph_get_remote_node(dev->of_node, 1, 0);
>>> +	remote2 = of_graph_get_remote_node(dev->of_node, 2, 0);
>>> +	fsl_ldb->ch0_enabled = (remote1 != NULL);
>>> +	fsl_ldb->ch1_enabled = (remote2 != NULL);
>>> +	panel_node = of_node_get(remote1 ? remote1 : remote2);
>>
>> You can even do this without the middle 'remote1' I think:
>>
>> panel_node = of_node_get(remote1 ? : remote2);
> 
> Apparently, but honestly with such short expressions clearly having no
> side effects I think it's not helping readability.

I think even the ternary operator itself isn't helpful much, but that's 
a matter of taste, and I don't have a better suggestion which would 
improve the readability either (I tried to expand it into if()... but 
that looks bad too).

No need to change anything.

[...]

Thanks for the patch.

      reply	other threads:[~2023-04-05 12:31 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-04-04  7:37 Luca Ceresoli
2023-04-05  3:28 ` Marek Vasut
2023-04-05  7:30   ` Luca Ceresoli
2023-04-05 12:31     ` Marek Vasut [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4b15b282-7243-3f75-4a2e-ba86791f6431@denx.de \
    --to=marex@denx.de \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=airlied@gmail.com \
    --cc=andrzej.hajda@intel.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jernej.skrabec@gmail.com \
    --cc=jonas@kwiboo.se \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luca.ceresoli@bootlin.com \
    --cc=neil.armstrong@linaro.org \
    --cc=paul.kocialkowski@bootlin.com \
    --cc=rfoss@kernel.org \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®