mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tom Lendacky <thomas.lendacky@amd.com>
To: "Pawel Zalewski (The Capable Hub)"
	<pzalewski@thegoodpenguin.co.uk>, John Allen <john.allen@amd.com>,
	Herbert Xu <herbert@gondor.apana.org.au>,
	"David S. Miller" <davem@davemloft.net>
Cc: linux-crypto@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] crypto: ccp: use named initializers for acpi_device_id
Date: Tue, 8 Sep 2026 15:21:08 -0500	[thread overview]
Message-ID: <4d1106dd-4427-489a-8d38-9da365b6a53b@amd.com> (raw)
In-Reply-To: <20260903-acpi-crypto-v1-1-253cc6fd9836@thegoodpenguin.co.uk>

On 9/3/26 10:42, Pawel Zalewski (The Capable Hub) wrote:
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
> 
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
> 
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>

Acked-by: Tom Lendacky <thomas.lendacky@amd.com>

> ---
>  drivers/crypto/ccp/sp-platform.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/crypto/ccp/sp-platform.c b/drivers/crypto/ccp/sp-platform.c
> index 3f9843fa77827..c7ac840cbe136 100644
> --- a/drivers/crypto/ccp/sp-platform.c
> +++ b/drivers/crypto/ccp/sp-platform.c
> @@ -40,8 +40,8 @@ static const struct sp_dev_vdata dev_vdata[] = {
>  };
>  
>  static const struct acpi_device_id sp_acpi_match[] = {
> -	{ "AMDI0C00", (kernel_ulong_t)&dev_vdata[0] },
> -	{ },
> +	{ .id = "AMDI0C00", .driver_data = (kernel_ulong_t)&dev_vdata[0] },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, sp_acpi_match);
>  
> 


  reply	other threads:[~2026-09-08 20:21 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-03 15:42 [PATCH 0/2] crypto: use designated " Pawel Zalewski (The Capable Hub)
2026-09-03 15:42 ` [PATCH 1/2] crypto: ccp: use named " Pawel Zalewski (The Capable Hub)
2026-09-08 20:21   ` Tom Lendacky [this message]
2026-09-16 12:53   ` Herbert Xu
2026-09-03 15:42 ` [PATCH 2/2] crypto: hisilicon/sec: " Pawel Zalewski (The Capable Hub)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4d1106dd-4427-489a-8d38-9da365b6a53b@amd.com \
    --to=thomas.lendacky@amd.com \
    --cc=davem@davemloft.net \
    --cc=herbert@gondor.apana.org.au \
    --cc=john.allen@amd.com \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pzalewski@thegoodpenguin.co.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®