mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Zefan Li <lizefan@huawei.com>
To: <zzuedu2000@163.com>, <James.Bottomley@HansenPartnership.com>
Cc: <tj@kernel.org>, <hannes@cmpxchg.org>, <cgroups@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <Markus.Elfring@web.de>,
	<songmuchun@bytedance.com>, <buddy.zhang@aliyun.com>
Subject: Re: [PATCH] cgroup: Refactor two assignments in css_task_iter_next_css_set()
Date: Mon, 15 Jun 2020 09:11:27 +0800	[thread overview]
Message-ID: <4d6a3864-b4b4-9b32-1349-c40b11e28a8f@huawei.com> (raw)
In-Reply-To: <20200614232224.1804-1-zzuedu2000@163.com>

On 2020/6/15 7:22, zzuedu2000@163.com wrote:
> On Sun, 2020-06-14 at 18:10 +0800, James.Bottomley@xxxxxxx wrote:
> 
>> it's arguable that having two statements instead of one makes the code
>> marginally more readable.
> 
> Above the function there is a similar line of code:
> l = it->tcset_pos->next;
> One line of code makes the code style consistent and more readable
> 

It would be much better if you are fixing a bug or developing a new feature
and while at it you do this cleanup conveniently, but this patch alone has
little value. 

      reply	other threads:[~2020-06-15  1:11 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-14  2:28 zzuedu2000
2020-06-14 18:10 ` James Bottomley
2020-06-14 23:22   ` zzuedu2000
2020-06-15  1:11     ` Zefan Li [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4d6a3864-b4b4-9b32-1349-c40b11e28a8f@huawei.com \
    --to=lizefan@huawei.com \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=Markus.Elfring@web.de \
    --cc=buddy.zhang@aliyun.com \
    --cc=cgroups@vger.kernel.org \
    --cc=hannes@cmpxchg.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=songmuchun@bytedance.com \
    --cc=tj@kernel.org \
    --cc=zzuedu2000@163.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®