From: Corrado Zoccolo <czoccolo@gmail.com>
To: Jeff Moyer <jmoyer@redhat.com>
Cc: Linux-Kernel <linux-kernel@vger.kernel.org>,
Jens Axboe <jens.axboe@oracle.com>
Subject: Re: [RFC V2 PATCH 1/5] cfq-iosched: adapt slice to number of processes doing I/O
Date: Thu, 22 Oct 2009 12:43:32 +0200 [thread overview]
Message-ID: <4e5e476b0910220343q2af96eedr69cda2594822af76@mail.gmail.com> (raw)
In-Reply-To: <x49tyxs7lge.fsf@segfault.boston.devel.redhat.com>
Hi Jeff,
On Wed, Oct 21, 2009 at 6:36 PM, Jeff Moyer <jmoyer@redhat.com> wrote:
> Corrado Zoccolo <czoccolo@gmail.com> writes:
>
> OK. The idea was to try to make the thing a bit more digestable.
> Honestly, I had to re-write it to figure out what it was doing. Could
> you rework it so the logic is more obvious to others and still correct?
What about:
/* interested queues (we consider only the ones with the same priority class) */
unsigned iq = cfq_get_avg_queues(cfqd, cfq_class_rt(cfqq));
unsigned sync_slice = cfqd->cfq_slice[1];
unsigned expected_latency = sync_slice * iq;
if (expected_latency > target_latency) {
unsigned base_low_slice = 2 * cfqd->cfq_slice_idle;
/* scale low_slice according to IO priority and sync vs async */
unsigned low_slice = min(slice, base_low_slice * slice / sync_slice);
/* the adapted slice value is scaled to fit all iqs into the target latency */
slice = max(slice * cfq_target_latency / expected_latency, low_slice);
}
BTW, the other complex part of the patch, i.e. the definition of
cfq_get_avg_queues, could be simplified if we hard-code the divisor,
that is currently defined outside to allow for some experimentation.
Thanks for your comments
Corrado
>
> Thanks!
> Jeff
>
--
__________________________________________________________________________
dott. Corrado Zoccolo mailto:czoccolo@gmail.com
PhD - Department of Computer Science - University of Pisa, Italy
--------------------------------------------------------------------------
next prev parent reply other threads:[~2009-10-22 10:43 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-10-20 18:11 Corrado Zoccolo
2009-10-21 15:16 ` Jeff Moyer
2009-10-21 15:57 ` Jeff Moyer
2009-10-21 16:32 ` Corrado Zoccolo
2009-10-21 16:36 ` Jeff Moyer
2009-10-22 10:43 ` Corrado Zoccolo [this message]
2009-10-26 15:10 ` Jeff Moyer
2009-10-26 15:14 ` Corrado Zoccolo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4e5e476b0910220343q2af96eedr69cda2594822af76@mail.gmail.com \
--to=czoccolo@gmail.com \
--cc=jens.axboe@oracle.com \
--cc=jmoyer@redhat.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome