From: Tvrtko Ursulin <tursulin@ursulin.net>
To: Philipp Stanner <pstanner@redhat.com>,
Luben Tuikov <ltuikov89@gmail.com>,
Matthew Brost <matthew.brost@intel.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Daniel Vetter <daniel@ffwll.ch>,
Danilo Krummrich <dakr@redhat.com>
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/2] drm/sched: warn about drm_sched_job_init()'s partial init
Date: Fri, 13 Sep 2024 13:21:14 +0100 [thread overview]
Message-ID: <4e85edc5-a155-460a-b470-aa7247b83230@ursulin.net> (raw)
In-Reply-To: <20240828094133.17402-4-pstanner@redhat.com>
On 28/08/2024 10:41, Philipp Stanner wrote:
> drm_sched_job_init()'s name suggests that after the function succeeded,
> parameter "job" will be fully initialized. This is not the case; some
> members are only later set, notably "job->sched" by drm_sched_job_arm().
>
> Document that drm_sched_job_init() does not set all struct members.
>
> Document that job->sched in particular is uninitialized before
> drm_sched_job_arm().
>
> Signed-off-by: Philipp Stanner <pstanner@redhat.com>
> ---
> Changes in v2:
> - Change grammar in the new comments a bit.
> ---
> drivers/gpu/drm/scheduler/sched_main.c | 4 ++++
> include/drm/gpu_scheduler.h | 7 +++++++
> 2 files changed, 11 insertions(+)
>
> diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
> index b0c8ad10b419..721373938c1e 100644
> --- a/drivers/gpu/drm/scheduler/sched_main.c
> +++ b/drivers/gpu/drm/scheduler/sched_main.c
> @@ -781,6 +781,10 @@ EXPORT_SYMBOL(drm_sched_resubmit_jobs);
> * Drivers must make sure drm_sched_job_cleanup() if this function returns
> * successfully, even when @job is aborted before drm_sched_job_arm() is called.
> *
> + * Note that this function does not assign a valid value to each struct member
> + * of struct drm_sched_job. Take a look at that struct's documentation to see
> + * who sets which struct member with what lifetime.
First sentence is fine, but the second I don't see the those details in
struct drm_sched_job. (And I am not saying that they must be listed. IMO
at some point it is better to have a high level overview than describe
the lifetime rules with individual members.)
> + *
> * WARNING: amdgpu abuses &drm_sched.ready to signal when the hardware
> * has died, which can mean that there's no valid runqueue for a @entity.
> * This function returns -ENOENT in this case (which probably should be -EIO as
> diff --git a/include/drm/gpu_scheduler.h b/include/drm/gpu_scheduler.h
> index 5acc64954a88..04a268cd22f1 100644
> --- a/include/drm/gpu_scheduler.h
> +++ b/include/drm/gpu_scheduler.h
> @@ -337,6 +337,13 @@ struct drm_sched_fence *to_drm_sched_fence(struct dma_fence *f);
> struct drm_sched_job {
> struct spsc_node queue_node;
> struct list_head list;
> +
> + /*
> + * The scheduler this job is or will be scheduled on.
> + *
> + * Gets set by drm_sched_arm(). Valid until the scheduler's backend_ops
> + * callback "free_job()" has been called.
This is interesting - I was not sure where lifetime for job->sched is
defined and couldn't find it browsing around. Where did you find the
clues to tie it to the free_job() callback?
Regards,
Tvrtko
> + */
> struct drm_gpu_scheduler *sched;
> struct drm_sched_fence *s_fence;
>
next prev parent reply other threads:[~2024-09-13 12:21 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-28 9:41 [PATCH v2 1/2] drm/sched: memset() 'job' in drm_sched_job_init() Philipp Stanner
2024-08-28 9:41 ` [PATCH v2 2/2] drm/sched: warn about drm_sched_job_init()'s partial init Philipp Stanner
2024-09-13 12:21 ` Tvrtko Ursulin [this message]
2024-09-04 13:53 ` [PATCH v2 1/2] drm/sched: memset() 'job' in drm_sched_job_init() Philipp Stanner
2024-09-13 11:56 ` Tvrtko Ursulin
2024-09-13 12:30 ` Philipp Stanner
2024-09-13 13:30 ` Tvrtko Ursulin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4e85edc5-a155-460a-b470-aa7247b83230@ursulin.net \
--to=tursulin@ursulin.net \
--cc=airlied@gmail.com \
--cc=dakr@redhat.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ltuikov89@gmail.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=matthew.brost@intel.com \
--cc=mripard@kernel.org \
--cc=pstanner@redhat.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®