From: "Maksim (Max) Krasnyanskiy" <maxk@qualcomm.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: linux-kernel@vger.kernel.org,
Linus Torvalds <torvalds@transmeta.com>,
Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
Subject: Re: [RFC] Rename _bh to _softirq
Date: Mon, 14 Oct 2002 12:58:22 -0700 [thread overview]
Message-ID: <5.1.0.14.2.20021014125359.0843e4d8@mail1.qualcomm.com> (raw)
In-Reply-To: <Pine.LNX.4.44.0210142119300.26635-100000@localhost.localdo main>
At 09:21 PM 10/14/2002 +0200, Ingo Molnar wrote:
>On Mon, 14 Oct 2002, Maksim (Max) Krasnyanskiy wrote:
>
> > Old BHs have been almost completely replaced with tasklets and softirqs.
> > Should we then rename _bh to _softirq ?
> > i.e
> > local_bh_disable() -> local_softirq_disable()
> > spin_lock_bh() -> spin_lock_softirq()
> > bh_lock_sock() -> softirq_sock_lock()
> > etc
>
>i wanted to do this as part of the irqlock cleanups, but generally we dont
>change existing interfaces unless it's really universally agreed upon. Eg.
>we had cli() around for a *long* time although it's an x86 (-mostly)
>instruction name. But yes, i agree, and there are a number of other
>renames that would make perfect sense.
We can keep compatibility defines, just like we have for cli().
i.e.
#define local_bh_disable local_softirq_disable
Max
prev parent reply other threads:[~2002-10-14 19:53 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-10-14 19:02 Maksim (Max) Krasnyanskiy
2002-10-13 19:17 ` THIS_MODULE->name=""; Ron Henry
2002-10-14 19:12 ` [RFC] Rename _bh to _softirq Jeff Garzik
2002-10-14 20:05 ` Maksim (Max) Krasnyanskiy
2002-10-14 19:21 ` Ingo Molnar
2002-10-15 1:57 ` kuznet
2002-10-15 16:34 ` Maksim (Max) Krasnyanskiy
2002-10-15 17:44 ` David S. Miller
2002-10-15 19:24 ` Maksim (Max) Krasnyanskiy
2002-10-15 19:42 ` David S. Miller
2002-10-15 20:23 ` Maksim (Max) Krasnyanskiy
2002-10-15 20:19 ` David S. Miller
2002-10-15 21:02 ` Maksim (Max) Krasnyanskiy
2002-10-15 20:58 ` David S. Miller
2002-10-15 21:27 ` Brad Hards
2002-10-15 21:28 ` Ingo Molnar
2002-10-15 21:20 ` Ingo Molnar
[not found] ` <Pine.LNX.4.44.0210152318150.26315-100000@localhost.localdo main>
2002-10-15 22:09 ` Maksim (Max) Krasnyanskiy
2002-10-15 19:55 ` Oliver Xymoron
2002-10-15 20:30 ` Maksim (Max) Krasnyanskiy
2002-10-15 21:17 ` Ingo Molnar
[not found] ` <Pine.LNX.4.44.0210142119300.26635-100000@localhost.localdo main>
2002-10-14 19:58 ` Maksim (Max) Krasnyanskiy [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5.1.0.14.2.20021014125359.0843e4d8@mail1.qualcomm.com \
--to=maxk@qualcomm.com \
--cc=kuznet@ms2.inr.ac.ru \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=torvalds@transmeta.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®