mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Lars-Peter Clausen <lars@metafoo.de>
To: olaf@aepfle.de
Cc: Bryan Wu <bryan.wu@canonical.com>,
	Richard Purdie <rpurdie@rpsys.net>,
	linux-leds@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] led: use correct name for /sys/devices/virtual/leds/ entries
Date: Wed, 18 Jul 2012 19:01:08 +0200	[thread overview]
Message-ID: <5006EBD4.8010601@metafoo.de> (raw)
In-Reply-To: <1342630156-16432-1-git-send-email-olaf@aepfle.de>

On 07/18/2012 06:49 PM, olaf@aepfle.de wrote:
> From: Olaf Hering <olaf@aepfle.de>
> 
> Follow naming according to Documentation/leds/leds-class.txt:
> LED Device Naming
> Is currently of the form:
> "devicename:colour:function"
> 
> Reported during openSuSE 11.1 testing.
> https://bugzilla.novell.com/show_bug.cgi?&id=468350
> 
> Signed-off-by: Olaf Hering <olaf@aepfle.de>
> 
> diff --git a/drivers/leds/ledtrig-default-on.c b/drivers/leds/ledtrig-default-on.c
> index a4ef54b..2efdd30 100644
> --- a/drivers/leds/ledtrig-default-on.c
> +++ b/drivers/leds/ledtrig-default-on.c
> @@ -23,7 +23,7 @@ static void defon_trig_activate(struct led_classdev *led_cdev)
>  }
>  
>  static struct led_trigger defon_led_trigger = {
> -	.name     = "default-on",
> +	.name     = "default::on",
>  	.activate = defon_trig_activate,
>  };
>  

That's a LED trigger, not a LED. So the LED naming convention doesn't apply
here and it does not even make sense to try to apply it. Also the patch
breaks all users of the default-on trigger.

- Lars

  reply	other threads:[~2012-07-18 16:57 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-18 16:49 olaf
2012-07-18 17:01 ` Lars-Peter Clausen [this message]
2012-07-18 17:32   ` Olaf Hering

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5006EBD4.8010601@metafoo.de \
    --to=lars@metafoo.de \
    --cc=bryan.wu@canonical.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=olaf@aepfle.de \
    --cc=rpurdie@rpsys.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome