From: John Stultz <john.stultz@linaro.org>
To: Anton Vorontsov <anton.vorontsov@linaro.org>
Cc: Jason Wessel <jason.wessel@windriver.com>,
Colin Cross <ccross@google.com>,
Alan Cox <alan@lxorguk.ukuu.org.uk>,
linux-kernel@vger.kernel.org, linaro-kernel@lists.linaro.org,
patches@linaro.org, kernel-team@android.com,
kgdb-bugreport@lists.sourceforge.net
Subject: Re: [PATCH 0/7] KDB: Kiosk (reduced capabilities) mode
Date: Wed, 14 Nov 2012 17:48:12 -0800 [thread overview]
Message-ID: <50A449DC.7070206@linaro.org> (raw)
In-Reply-To: <20121016011724.GB23146@lizard>
On 10/15/2012 06:17 PM, Anton Vorontsov wrote:
> Hello Jason,
>
> Just as promised, I'm resending the series after the merge window.
>
> This patchset implements "kiosk" mode for KDB debugger. The mode reduces
> kdb features, so that it is no longer possible to leak sensitive data via
> the debugger, and not possible to change program flow in a predefined
> manner by an ordinary user. Root can control the capability.
>
> There are a few patches, some are just cleanups, some are churn-ish
> cleanups, but inevitable. And the rest implements the mode -- after all
> the preparations, everything is pretty straightforward.
>
Ping? Did this patchset fall through the cracks? Any issues left to
address?
thanks
-john
next prev parent reply other threads:[~2012-11-15 1:48 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-16 1:17 Anton Vorontsov
2012-10-16 1:17 ` [PATCH 1/7] kdb: Remove currently unused kdbtab_t->cmd_flags Anton Vorontsov
2012-10-16 1:18 ` [PATCH 2/7] kdb: Rename kdb_repeat_t to kdb_cmdflags_t, cmd_repeat to cmd_flags Anton Vorontsov
2012-10-16 1:18 ` [PATCH 3/7] kdb: Rename kdb_register_repeat() to kdb_register_flags() Anton Vorontsov
2012-10-16 1:18 ` [PATCH 4/7] kdb: Use KDB_REPEAT_* values as flags Anton Vorontsov
2012-10-16 1:18 ` [PATCH 5/7] kdb: Remove KDB_REPEAT_NONE flag Anton Vorontsov
2012-10-16 1:18 ` [PATCH 6/7] kdb: Mark safe commands as KDB_SAFE and KDB_SAFE_NO_ARGS Anton Vorontsov
2012-10-16 1:18 ` [PATCH 7/7] kdb: Add kiosk mode Anton Vorontsov
2012-11-15 1:48 ` John Stultz [this message]
-- strict thread matches above, loose matches on Subject: below --
2012-07-26 14:25 [PATCH 0/7] KDB: Kiosk (reduced capabilities) mode Anton Vorontsov
2012-07-27 19:30 ` Colin Cross
2012-07-28 1:26 ` Anton Vorontsov
2012-07-28 1:49 ` John Stultz
2012-07-28 1:53 ` Colin Cross
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=50A449DC.7070206@linaro.org \
--to=john.stultz@linaro.org \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=anton.vorontsov@linaro.org \
--cc=ccross@google.com \
--cc=jason.wessel@windriver.com \
--cc=kernel-team@android.com \
--cc=kgdb-bugreport@lists.sourceforge.net \
--cc=linaro-kernel@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=patches@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome