From: Stephen Warren <swarren@wwwdotorg.org>
To: Axel Lin <axel.lin@ingics.com>
Cc: Mark Brown <broonie@opensource.wolfsonmicro.com>,
Mike Rapoport <mike@compulab.co.il>,
Laxman Dewangan <ldewangan@nvidia.com>,
Liam Girdwood <lgirdwood@gmail.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] regulator: tps6586x: Having slew rate settings for other than SM0/1 is not fatal
Date: Tue, 19 Feb 2013 19:12:48 -0700 [thread overview]
Message-ID: <51243120.1030101@wwwdotorg.org> (raw)
In-Reply-To: <CAFRkauAAdArpG5x8MeyZJXUYqi00e669Hr6gPHGO8fxTJnE5YQ@mail.gmail.com>
On 02/19/2013 05:53 PM, Axel Lin wrote:
> 2013/2/20 Stephen Warren <swarren@wwwdotorg.org>:
>> On 02/16/2013 04:50 AM, Axel Lin wrote:
>>> Ignore the setting and show "Only SM0/SM1 can set slew rate" warning is enough,
>>> then we can return 0 instead of -EINVAL in tps6586x_regulator_set_slew_rate().
>>>
>>> Otherwise, probe() fails.
>>
>> Why does probe() fail; what is trying to set a slew rate on a regulator
>> that doesn't support it? At least a few days ago in linux-next, this
>> patch wasn't needed AFAIK. Is the problem something new?
>>
>
> Oh, sorry for my poor Engilish.
> I mean probe fails because of having slew rate settings for other than SM0/1
> seems not necessary.
>
> In tps6586x_regulator_set_slew_rate() it uses dev_warn rather than dev_err
> for the default case.
> We can either using "dev_warn with return 0" or use "dev_err with
> return -EINVAL"
> in tps6586x_regulator_set_slew_rate().
Oh right, I understand. s/dev_warn/dev_err/ seems more appropriate to
me, I think.
prev parent reply other threads:[~2013-02-20 2:12 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-02-16 11:50 Axel Lin
2013-02-19 16:47 ` Stephen Warren
2013-02-19 18:26 ` Mark Brown
2013-02-19 19:32 ` Stephen Warren
2013-02-19 20:07 ` Mark Brown
2013-02-20 0:53 ` Axel Lin
2013-02-20 2:12 ` Stephen Warren [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=51243120.1030101@wwwdotorg.org \
--to=swarren@wwwdotorg.org \
--cc=axel.lin@ingics.com \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=ldewangan@nvidia.com \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mike@compulab.co.il \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome