From: Eduardo Valentin <eduardo.valentin@ti.com>
To: Zhang Rui <rui.zhang@intel.com>
Cc: Eduardo Valentin <eduardo.valentin@ti.com>,
<linux-pm@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<amit.daniel@samsung.com>, <durgadoss.r@intel.com>,
<andi@lisas.de>
Subject: Re: [PATCH V2 1/3] Thermal: rename thermal_sys.c to thermal_core.c
Date: Fri, 12 Apr 2013 08:21:15 -0400 [thread overview]
Message-ID: <5167FC3B.2070200@ti.com> (raw)
In-Reply-To: <1365729176.2183.20.camel@rzhang1-mobl4>
On 11-04-2013 21:12, Zhang Rui wrote:
> On Thu, 2013-04-04 at 16:24 -0400, Eduardo Valentin wrote:
>> On 29-03-2013 10:26, Zhang Rui wrote:
>>> this is the preparation work to build all the thermal core framework
>>> source file, like governors, cpu cooling, etc, into one module.
>>>
>>> No functional change in this patch.
>>>
>>> Signed-off-by: Zhang Rui <rui.zhang@intel.com>
>>
>> Durga and me have already reviewed and acked this patch. Can you please
>> add our Acked-by on this patch?
>
> sure.
> BTW, I've talked with Rafael, and we agree on adding prefix "acpi_" for
> ACPI drivers, and then we can rename thermal_sys.ko to thermal.ko.
>
Good!
> But I'll try to push this patch set for 3.10, to fix the problem on
> hand, also for easily back porting to 3.8 and 3.9 stable kernel.
> Then, we'll rename a couple of ACPI drivers and then thermal driver in
> 3.11.
>
> what do you think?
I am OK with this approach.
Thanks for keeping this up.
>
> thanks,
> rui
>
>>
>>> ---
>>> drivers/thermal/Makefile | 1 +
>>> drivers/thermal/{thermal_sys.c => thermal_core.c} | 0
>>> 2 files changed, 1 insertion(+)
>>> rename drivers/thermal/{thermal_sys.c => thermal_core.c} (100%)
>>>
>>> diff --git a/drivers/thermal/Makefile b/drivers/thermal/Makefile
>>> index d3a2b38..b2009bd 100644
>>> --- a/drivers/thermal/Makefile
>>> +++ b/drivers/thermal/Makefile
>>> @@ -3,6 +3,7 @@
>>> #
>>>
>>> obj-$(CONFIG_THERMAL) += thermal_sys.o
>>> +thermal_sys-y += thermal_core.o
>>>
>>> # governors
>>> obj-$(CONFIG_THERMAL_GOV_FAIR_SHARE) += fair_share.o
>>> diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_core.c
>>> similarity index 100%
>>> rename from drivers/thermal/thermal_sys.c
>>> rename to drivers/thermal/thermal_core.c
>>>
>>
>
>
>
>
next prev parent reply other threads:[~2013-04-12 12:21 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-03-29 14:26 [PATCH V2 0/3] Thermal: build all thermal framework code into thermal_sys module Zhang Rui
2013-03-29 14:26 ` [PATCH V2 1/3] Thermal: rename thermal_sys.c to thermal_core.c Zhang Rui
2013-04-04 20:24 ` Eduardo Valentin
2013-04-12 1:12 ` Zhang Rui
2013-04-12 12:21 ` Eduardo Valentin [this message]
2013-03-29 14:26 ` [PATCH V2 2/3] Thermal: build thermal governors into thermal_sys module Zhang Rui
2013-03-29 14:26 ` [PATCH V2 3/3] Thermal: build cpu_cooling code " Zhang Rui
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5167FC3B.2070200@ti.com \
--to=eduardo.valentin@ti.com \
--cc=amit.daniel@samsung.com \
--cc=andi@lisas.de \
--cc=durgadoss.r@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rui.zhang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome