From: Krishna Kurapati PSSNV <quic_kriskura@quicinc.com>
To: Johan Hovold <johan@kernel.org>
Cc: Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Andy Gross <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Konrad Dybcio <konrad.dybcio@linaro.org>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Wesley Cheng <quic_wcheng@quicinc.com>,
Conor Dooley <conor+dt@kernel.org>,
<cros-qcom-dts-watchers@chromium.org>,
<linux-usb@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linux-arm-msm@vger.kernel.org>, <devicetree@vger.kernel.org>,
<quic_ppratap@quicinc.com>, <quic_jackp@quicinc.com>
Subject: Re: [PATCH v2 2/6] usb: dwc3: qcom: Rename hs_phy_irq to qusb2_phy_irq
Date: Fri, 8 Dec 2023 17:44:41 +0530 [thread overview]
Message-ID: <516aeb55-69ad-460c-9757-6ad8a203b693@quicinc.com> (raw)
In-Reply-To: <ZXHz-HYgVLbgFp2k@hovoldconsulting.com>
On 12/7/2023 10:04 PM, Johan Hovold wrote:
> On Thu, Dec 07, 2023 at 09:17:32PM +0530, Krishna Kurapati PSSNV wrote:
>> On 12/7/2023 8:58 PM, Johan Hovold wrote:
>
>>> Here too you should say something about why this won't break any systems
>>> booting using an older devicetree. Specifically, the QUSB2 PHY interrupt
>>> has never been armed on any system running mainline as those bits never
>>> made it upstream.
>>>
>>> So an alternative to this could also be to just drop the QUSB2 PHY
>>> interrupt handling from this driver for now. >
>
>> So, are you suggesting that we drop the whole patch ?
>
> No, I meant that an alternative could be to drop the current hs_phy_irq
> handling from the driver.
>
>> I assume if the older kernels are using old DT, they would be using an
>> old driver version too right ?
>
> No, and this is part of the devicetree ABI as we discussed the other
> week.
>
> You should generally be able to continue booting with an older devicetree
> on a newer kernel (even if newer functionality may not be enabled then).
>
>> Is there a case where DT is not updated but driver is ? Because if we
>> drop this patch from series, targets with updated DT's would break.
>
> Actually they would not due to the fact that the QUSB2 PHY interrupt is
> currently never armed in the PHY (and the interrupts are looked up by
> name and are considered optional by the driver).
>
> But simply dropping this patch is not an option here. I'm fine with this
> patch as it is, but the reason we can merge it is that those interrupts
> are currently not actually used. Otherwise, this would break older
> devicetrees.
>
> But this also means, we could consider dropping the current hs_phy_irq
> handling altogether.
>
> Hmm. Looking at the qusb2_phy_runtime_suspend() again now I see that the
> interrupt is actually armed on runtime suspend, it's just that it is
> configured incorrectly and would wakeup immediately if someone ever
> exercised this path.
>
> Specifically, the bits that would set those PHY_MODE_USB_HOST_HS modes
> (that should never have been merged) never made it upstream so this code
> is just dead code currently. I said before I'll look into ripping this
> out, but yeah, I'm swamped with work as usual (and it has been sitting
> there dead for years so there's no rush).
>
> So to summarise, the QUSB2 wakeup handling is incomplete and broken, so
> we won't actually make things worse by renaming the interrupts. If this
> was working, we would need to continue supporting the old names, though.
>
Thanks for the review. Since renaming the interrupts won't be an issue,
I will keep this patch as is in that case in v3.
Regards,
Krishna,
next prev parent reply other threads:[~2023-12-08 12:15 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-04 10:09 [PATCH v2 0/6] Refine USB interrupt vectors on Qualcomm platforms Krishna Kurapati
2023-12-04 10:09 ` [PATCH v2 1/6] dt-bindings: usb: dwc3: Clean up hs_phy_irq in bindings Krishna Kurapati
2023-12-07 15:23 ` Johan Hovold
2023-12-07 15:44 ` Krishna Kurapati PSSNV
2023-12-07 16:13 ` Johan Hovold
2023-12-08 16:29 ` Rob Herring
2023-12-09 8:02 ` Krzysztof Kozlowski
2023-12-04 10:09 ` [PATCH v2 2/6] usb: dwc3: qcom: Rename hs_phy_irq to qusb2_phy_irq Krishna Kurapati
2023-12-07 15:28 ` Johan Hovold
2023-12-07 15:47 ` Krishna Kurapati PSSNV
2023-12-07 16:34 ` Johan Hovold
2023-12-08 12:14 ` Krishna Kurapati PSSNV [this message]
2023-12-04 10:09 ` [PATCH v2 3/6] arm64: dts: qcom: Fix hs_phy_irq for QUSB2 targets Krishna Kurapati
2023-12-07 15:32 ` Johan Hovold
2023-12-04 10:09 ` [PATCH v2 4/6] arm64: dts: qcom: Fix hs_phy_irq for non-QUSB2 targets Krishna Kurapati
2023-12-04 10:09 ` [PATCH v2 5/6] arm64: dts: qcom: Fix hs_phy_irq for SDM670/SDM845/SM6350 Krishna Kurapati
2023-12-04 10:09 ` [PATCH v2 6/6] arm64: dts: qcom: Add missing interrupts for qcs404/ipq5332 Krishna Kurapati
2023-12-07 15:36 ` Johan Hovold
2023-12-07 14:53 ` [PATCH v2 0/6] Refine USB interrupt vectors on Qualcomm platforms Johan Hovold
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=516aeb55-69ad-460c-9757-6ad8a203b693@quicinc.com \
--to=quic_kriskura@quicinc.com \
--cc=Thinh.Nguyen@synopsys.com \
--cc=agross@kernel.org \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=cros-qcom-dts-watchers@chromium.org \
--cc=devicetree@vger.kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=johan@kernel.org \
--cc=konrad.dybcio@linaro.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=quic_jackp@quicinc.com \
--cc=quic_ppratap@quicinc.com \
--cc=quic_wcheng@quicinc.com \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®