mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Eduardo Valentin <eduardo.valentin@ti.com>
To: Pavel Machek <pavel@ucw.cz>
Cc: Eduardo Valentin <eduardo.valentin@ti.com>, <rui.zhang@intel.com>,
	<linux-pm@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
	<durgadoss.r@intel.com>
Subject: Re: [PATCHv2 0/3] thermal: lookup temperature
Date: Mon, 22 Apr 2013 09:11:15 -0400	[thread overview]
Message-ID: <517536F3.5050702@ti.com> (raw)
In-Reply-To: <20130422110647.GB24710@amd.pavel.ucw.cz>

Hello Pavel,

On 22-04-2013 07:06, Pavel Machek wrote:
> Hi!
>
>> Here is V2 of temperature lookup helper function. This has been
>> split into two API as suggested on V1.
>>
>> The usage of it is exemplified on patch 03.
>>
>>
>> Eduardo Valentin (3):
>>    thermal: introduce thermal_zone_get_zone_by_name helper function
>
> Is the function name maybe a bit long? Perhaps using tz_ prefix
> instead of "thermal_zone_" would help? or thermal_get_by_name? tz_get_by_name?
>
> 									Pavel
>
This patch follows the naming convention on this file. If we are  going 
to use different prefixes, then I suggest sending a patch that changes 
the functions that are exported by this file. Besides the names you 
suggested do not reflect exactly the purpose of the introduced API.

Thanks for your suggestion.

All best,

Thanks.

      reply	other threads:[~2013-04-22 13:11 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-03 22:13 Eduardo Valentin
2013-04-03 22:13 ` [PATCHv2 1/3] thermal: introduce thermal_zone_get_zone_by_name helper function Eduardo Valentin
2013-04-04 17:12   ` R, Durgadoss
2013-04-04 20:22     ` Eduardo Valentin
2013-04-05  4:57       ` R, Durgadoss
2013-04-03 22:13 ` [PATCHv2 2/3] thermal: expose thermal_zone_get_temp API Eduardo Valentin
2013-04-04 17:13   ` R, Durgadoss
2013-04-03 22:13 ` [PATCHv2 3/3] staging: ti-soc-thermal: remove external heat while extrapolating hotspot Eduardo Valentin
2013-04-22 11:06 ` [PATCHv2 0/3] thermal: lookup temperature Pavel Machek
2013-04-22 13:11   ` Eduardo Valentin [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=517536F3.5050702@ti.com \
    --to=eduardo.valentin@ti.com \
    --cc=durgadoss.r@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=pavel@ucw.cz \
    --cc=rui.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome