From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752729AbbJMMKQ (ORCPT ); Tue, 13 Oct 2015 08:10:16 -0400 Received: from mout.kundenserver.de ([212.227.17.10]:65421 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751733AbbJMMKO (ORCPT ); Tue, 13 Oct 2015 08:10:14 -0400 From: Arnd Bergmann To: Alim Akhtar Cc: linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org, JBottomley@odin.com, vinholikatti@gmail.com, amit.daniel@samsung.com, essuuj@gmail.com, devicetree@vger.kernel.org Subject: Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller Date: Tue, 13 Oct 2015 14:10:01 +0200 Message-ID: <5214359.Szp3KsYW6e@wuerfel> User-Agent: KMail/4.11.5 (Linux/3.16.0-10-generic; KDE/4.11.5; x86_64; ; ) In-Reply-To: <561CECB2.2090208@samsung.com> References: <1443686970-28104-1-git-send-email-alim.akhtar@samsung.com> <1457698.WJ3mz2FHZZ@wuerfel> <561CECB2.2090208@samsung.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:SrXadB3ARxDZ5MXGTerzC/3zvJx3rZ3XV3/SNB+kLtzYmZ+5T+K 0DMx6XjzrueCFiaPKRqPlzOjCIQlb8CUQAt6Q0O/0UpriXBpP2sKvQ43OWOxbvEAJRkgDGf FxrsgbV7kSedGlx/BFdelGHEdUutiCCzrUZ8rqZEy9UKEESjF4HimZwm5Hhz1d9+dUv34h+ XLMYr2M5jS6K3W8JubMCQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:ZXkFJUW3Ra8=:1OkSvuBgCW4rFFAB1h1O6t Z4GBSvYbMvwM6njd382KGLF5X1BfFQ4wNkaVjM6bOdDrNgW+Q3uEUPCrmDVoJ92YripvoL8lA Qem43vDU/eWjEw408Ah8K5D+SnKtjtTwTSm6BeOAVqzwujYaHrjbnHWSgzIGuPT+JYHeGj3jV QWRIusyBWuBuHX9m3kb+Q2Pj67WH8wR+xx+5qLrKay/6ppb5g6klm7YfFr89DgKGMzrCvSwUp eKz5HrORFFEAhrZzWyNCaNK3p+R6A8OmjaOO1bRetuCYKroU8wBEPF/yZL1RyiOi1S2FFr2TM L9Xr4Ag47a9LQBm9W2ImTtS5RGDAaROcxNFBAURnogfzGqB5jKxLE407h++27JytTerXVRi7I doB2uVzm/Y3FVej/3geU3Ke0UwRTBOufwyeJiKqKShc4q82MPr4baKX3HD2dm0imIMcRJSGu9 J5sgZVsL0xFQtEJdbTlcIAaMh4bprDkrHNPocRUixk+aSzTo8fcUeO760f3wMwV1h8PbSZibD Nrwj3X8TZAHOX3bdflt2GjoxXj90OIorJFmDr914Gp5lYqcfxrpZjy95m8vpeDZdF+JXc70p+ aiC8nBx1aMx72mFnr7B7KEXBiLsE4f4ukn4w7QCwYr8OJGfLixz4+eLkDA8utSkhVHMtlSUGd JIL5AaLfutsXHsgAq/yDjH9VcZs7lyIk6BPYrK/bmZTcfGyV04pm3DEL2uhVhdLFmsftDy0et E5N4iLV7PV+k0VQO Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tuesday 13 October 2015 17:06:18 Alim Akhtar wrote: > > Better rename them to "core", "ref" and "iface", no point requiring to > > spell out "clk" here. > > > >> + ufs,pwr-attr-mode = "FAST"; > > > > A string is rather unusual here, what are the allowed values? Could you > > use a boolean property instead? > > > will update the binding, supported modes are FAST, SLOW, FAST_auto etc, > so kept the string for more readability > > >> + ufs,pwr-attr-lane = /bits/ 8 <2>; > >> + ufs,pwr-attr-gear = /bits/ 8 <2>; > > > > Why the "/bits/ 8" ? > > > I am using of_property_read_u8() to read 8 bit value from property. > I still think it would be better to stay with conventional methods here, and change the code accordingly. You can easily use of_property_read_u32 for the last two properties. Arnd