From: Eric Florin <ericflorin@google.com>
To: teddy.wang@siliconmotion.com
Cc: sudipm.mukherjee@gmail.com, gregkh@linuxfoundation.org,
linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org,
Eric Florin <ericflorin@google.com>
Subject: [PATCH 4/6] staging: sm750fb: rename `dPitch` parameter
Date: Tue, 27 May 2025 10:11:26 -0700 [thread overview]
Message-ID: <5250c76b824f133c04135b0d82b18d85cd958852.1748365488.git.ericflorin@google.com> (raw)
In-Reply-To: <cover.1748365488.git.ericflorin@google.com>
Rename `dPitch` to `d_pitch` in `sm750_hw_copyarea` to conform with
kernel style guidelines as reported by checkpatch.pl
CHECK: Avoid CamelCase: <dPitch>
Signed-off-by: Eric Florin <ericflorin@google.com>
---
drivers/staging/sm750fb/sm750_accel.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750_accel.c b/drivers/staging/sm750fb/sm750_accel.c
index e5f1f021768b..ea64e10d4814 100644
--- a/drivers/staging/sm750fb/sm750_accel.c
+++ b/drivers/staging/sm750fb/sm750_accel.c
@@ -137,7 +137,7 @@ int sm750_hw_fillrect(struct lynx_accel *accel,
* @sx: Starting x coordinate of source surface
* @sy: Starting y coordinate of source surface
* @d_base: Address of destination: offset in frame buffer
- * @dPitch: Pitch value of destination surface in BYTE
+ * @d_pitch: Pitch value of destination surface in BYTE
* @Bpp: Color depth of destination surface
* @dx: Starting x coordinate of destination surface
* @dy: Starting y coordinate of destination surface
@@ -148,7 +148,7 @@ int sm750_hw_fillrect(struct lynx_accel *accel,
int sm750_hw_copyarea(struct lynx_accel *accel,
unsigned int s_base, unsigned int s_pitch,
unsigned int sx, unsigned int sy,
- unsigned int d_base, unsigned int dPitch,
+ unsigned int d_base, unsigned int d_pitch,
unsigned int Bpp, unsigned int dx, unsigned int dy,
unsigned int width, unsigned int height,
unsigned int rop2)
@@ -160,7 +160,7 @@ int sm750_hw_copyarea(struct lynx_accel *accel,
de_ctrl = 0;
/* If source and destination are the same surface, need to check for overlay cases */
- if (s_base == d_base && s_pitch == dPitch) {
+ if (s_base == d_base && s_pitch == d_pitch) {
/* Determine direction of operation */
if (sy < dy) {
/* +----------+
@@ -249,7 +249,7 @@ int sm750_hw_copyarea(struct lynx_accel *accel,
* pixel values. Need Byte to pixel conversion.
*/
write_dpr(accel, DE_PITCH,
- ((dPitch / Bpp << DE_PITCH_DESTINATION_SHIFT) &
+ ((d_pitch / Bpp << DE_PITCH_DESTINATION_SHIFT) &
DE_PITCH_DESTINATION_MASK) |
(s_pitch / Bpp & DE_PITCH_SOURCE_MASK)); /* dpr10 */
@@ -259,7 +259,7 @@ int sm750_hw_copyarea(struct lynx_accel *accel,
* for a given point.
*/
write_dpr(accel, DE_WINDOW_WIDTH,
- ((dPitch / Bpp << DE_WINDOW_WIDTH_DST_SHIFT) &
+ ((d_pitch / Bpp << DE_WINDOW_WIDTH_DST_SHIFT) &
DE_WINDOW_WIDTH_DST_MASK) |
(s_pitch / Bpp & DE_WINDOW_WIDTH_SRC_MASK)); /* dpr3c */
--
2.49.0.1151.ga128411c76-goog
next prev parent reply other threads:[~2025-05-27 17:11 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-27 17:11 [PATCH 0/6] staging: sm750fb: cleanup `sm750_hw_copyarea` Eric Florin
2025-05-27 17:11 ` [PATCH 1/6] staging: sm750fb: rename `sBase` parameter Eric Florin
2025-06-19 15:29 ` Greg KH
2025-05-27 17:11 ` [PATCH 2/6] staging: sm750fb: rename `sPitch` parameter Eric Florin
2025-06-19 15:29 ` Greg KH
2025-05-27 17:11 ` [PATCH 3/6] staging: sm750fb: rename `dBase` parameter Eric Florin
2025-06-19 15:30 ` Greg KH
2025-05-27 17:11 ` Eric Florin [this message]
2025-06-19 15:29 ` [PATCH 4/6] staging: sm750fb: rename `dPitch` parameter Greg KH
2025-05-27 17:11 ` [PATCH 5/6] staging: sm750fb: rename `Bpp` parameter Eric Florin
2025-06-19 15:30 ` Greg KH
2025-05-27 17:11 ` [PATCH 6/6] staging: sm750fb: Rename local var `nDirection` Eric Florin
2025-06-19 15:30 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5250c76b824f133c04135b0d82b18d85cd958852.1748365488.git.ericflorin@google.com \
--to=ericflorin@google.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=sudipm.mukherjee@gmail.com \
--cc=teddy.wang@siliconmotion.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®