From: micky <micky_ching@realsil.com.cn>
To: Dan Carpenter <dan.carpenter@oracle.com>
Cc: <cjb@laptop.org>, <sameo@linux.intel.com>,
<gregkh@linuxfoundation.org>, <linux-mmc@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <wei_wang@realsil.com.cn>,
<devel@linuxdriverproject.org>
Subject: Re: [PATCH 2/2] mmc: rtsx: modify phase searching method for tunning
Date: Wed, 20 Nov 2013 17:13:13 +0800 [thread overview]
Message-ID: <528C7D29.4040901@realsil.com.cn> (raw)
In-Reply-To: <20131120081758.GX5302@mwanda>
Hi Dan:
On 11/20/2013 04:17 PM, Dan Carpenter wrote:
> On Tue, Nov 19, 2013 at 07:10:35PM +0800, micky_ching@realsil.com.cn wrote:
>> -static u8 sd_search_final_phase(struct realtek_pci_sdmmc *host, u32 phase_map)
>> +static inline u32 sd_get_phase_point(u32 phase_map, unsigned int idx)
>> {
>> - struct timing_phase_path path[MAX_PHASE + 1];
>> - int i, j, cont_path_cnt;
>> - int new_block, max_len, final_path_idx;
>> - u8 final_phase = 0xFF;
>> + idx &= MAX_PHASE;
>> + return phase_map & (1 << idx);
>> +}
>> +
> This function is confusing....
>
> MAX_PHASE is a terrible name. It's in a global header but it doesn't
> have a prefix. It should be #define RTS_MAX_PHASE. It's weird that we
> are using it both as a number and as bit mask. It's weird that we
> always add a "+ 1" to MAX_PHASE. It means the name is chosen poorly.
> Maybe it should be:
>
> #define RTS_MAX_PHASE 32
> #define RTS_PHASE_MASK 0x1f
That's good, I will modify and resend.
> So this function takes a phase_map and an index and it wraps the index
> by masking away the top bits then it tests to see if the wrapped index
> bit is set? The wrapping is very strange.
We use this function to find whether the bit of index in the phase_map
is 1. The index can be twice as MAX_PHASE(reach to 63), because we use
a unidirectional search, start search continuous phase to found the
max continuous length from 0, 1, ..., to 31. When we start from
bit31, index 32 should wrap as 0. This function can be replaced by mod
function(idx %= MAX_PHASE + 1).
> The name of the function is sd_get_phase_point() but we only test to
> see if it returns zero. The name of the function is not helpful.
> "sd" is a generic prefix.
> "get" is misleading because we don't "get" anything it only returns zero
> on success?
> "phase_point" might be helpful but I don't know what a phase_point is.
> Add a comment about that maybe.
Yes, thank you for your suggestion, the function name is really not good.
I want use test_phase_bit(u32 phase_map, unsigned int bit), is that ok?
> regards,
> dan carpenter
>
> .
>
--
Best Regards
Micky.
prev parent reply other threads:[~2013-11-20 9:12 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-11-19 11:10 [PATCH 0/2] fix sd power bug and modify phase-searching method micky_ching
2013-11-19 11:10 ` [PATCH 1/2] mmc: rtsx: fix card poweroff bug micky_ching
2013-11-19 11:10 ` [PATCH 2/2] mmc: rtsx: modify phase searching method for tunning micky_ching
2013-11-20 8:17 ` Dan Carpenter
2013-11-20 9:13 ` micky [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=528C7D29.4040901@realsil.com.cn \
--to=micky_ching@realsil.com.cn \
--cc=cjb@laptop.org \
--cc=dan.carpenter@oracle.com \
--cc=devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mmc@vger.kernel.org \
--cc=sameo@linux.intel.com \
--cc=wei_wang@realsil.com.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®