From: Masami Hiramatsu <masami.hiramatsu.pt@hitachi.com>
To: Namhyung Kim <namhyung@kernel.org>
Cc: Steven Rostedt <rostedt@goodmis.org>,
Oleg Nesterov <oleg@redhat.com>,
Hyeoncheol Lee <cheol.lee@lge.com>,
Srikar Dronamraju <srikar@linux.vnet.ibm.com>,
"zhangwei(Jovi)" <jovi.zhangwei@huawei.com>,
Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
Hemant Kumar <hkshaw@linux.vnet.ibm.com>,
LKML <linux-kernel@vger.kernel.org>,
Namhyung Kim <namhyung.kim@lge.com>
Subject: Re: Re: [PATCH 02/17] tracing/probes: Fix basic print type functions
Date: Thu, 28 Nov 2013 13:16:09 +0900 [thread overview]
Message-ID: <5296C389.7060600@hitachi.com> (raw)
In-Reply-To: <1385563168.1685.36.camel@leonhard>
(2013/11/27 23:39), Namhyung Kim wrote:
> Hi Masami,
>
> 2013-11-27 (수), 20:57 +0900, Masami Hiramatsu:
>> (2013/11/27 15:19), Namhyung Kim wrote:
>>>
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(u8, "%x", unsigned int)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(u16, "%x", unsigned int)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(u32, "%lx", unsigned long)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(u64, "%llx", unsigned long long)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(s8, "%d", int)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(s16, "%d", int)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(s32, "%ld", long)
>>> -DEFINE_BASIC_PRINT_TYPE_FUNC(s64, "%lld", long long)
>>> +DEFINE_BASIC_PRINT_TYPE_FUNC(u8 , "%#x")
>>> +DEFINE_BASIC_PRINT_TYPE_FUNC(u16, "%#x")
>>> +DEFINE_BASIC_PRINT_TYPE_FUNC(u32, "%#x")
>>> +DEFINE_BASIC_PRINT_TYPE_FUNC(u64, "%#Lx")
>>
>> As I said I'd like to ask you to change it in %x.
>>
>> I just checked in Fedora18, but %#x is not supported on this glibc-2.17.
>> Since this format is exported via debugfs (format file), I think %x is
>> better.
>
> Hmm.. but in most cases it's used for printf() not scanf(), right? In
> that case adding 0x prefix will help human readers a lot.
>
> How about mandating the prefix with "0x%x"? This way it can be used
> both for printf() and scanf() IMHO.
Agreed, you can just use "0x%x" in above case instead of "%#x". :)
For other traceevents, from the human readability point of view,
I think we should move all the event format should use 0x%x instead
of %x, because sometimes it confuse users (e.g. 100 => 0x64, without 0x,
it is just "64").
Thank you,
--
Masami HIRAMATSU
IT Management Research Dept. Linux Technology Center
Hitachi, Ltd., Yokohama Research Laboratory
E-mail: masami.hiramatsu.pt@hitachi.com
next prev parent reply other threads:[~2013-11-28 4:16 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-11-27 6:19 [PATCHSET 00/17] tracing/uprobes: Add support for more fetch methods (v7) Namhyung Kim
2013-11-27 6:19 ` [PATCH 01/17] tracing/uprobes: Fix documentation of uprobe registration syntax Namhyung Kim
2013-11-29 9:37 ` Srikar Dronamraju
2013-11-27 6:19 ` [PATCH 02/17] tracing/probes: Fix basic print type functions Namhyung Kim
2013-11-27 11:57 ` Masami Hiramatsu
2013-11-27 14:39 ` Namhyung Kim
2013-11-28 4:16 ` Masami Hiramatsu [this message]
2013-11-28 6:57 ` Namhyung Kim
2013-11-27 6:19 ` [PATCH 03/17] tracing/kprobes: Factor out struct trace_probe Namhyung Kim
2013-11-29 9:25 ` Srikar Dronamraju
2013-12-02 7:20 ` Namhyung Kim
2013-12-03 1:48 ` Namhyung Kim
2013-11-27 6:19 ` [PATCH 04/17] tracing/uprobes: Convert to " Namhyung Kim
2013-11-29 9:38 ` Srikar Dronamraju
2013-11-27 6:19 ` [PATCH 05/17] tracing/kprobes: Move common functions to trace_probe.h Namhyung Kim
2013-11-27 6:19 ` [PATCH 06/17] tracing/probes: Integrate duplicate set_print_fmt() Namhyung Kim
2013-11-27 6:19 ` [PATCH 07/17] tracing/probes: Move fetch function helpers to trace_probe.h Namhyung Kim
2013-11-27 6:19 ` [PATCH 08/17] tracing/probes: Split [ku]probes_fetch_type_table Namhyung Kim
2013-12-02 17:04 ` Oleg Nesterov
2013-12-02 17:09 ` Oleg Nesterov
2013-12-03 2:24 ` Namhyung Kim
2013-11-27 6:19 ` [PATCH 09/17] tracing/probes: Implement 'stack' fetch method for uprobes Namhyung Kim
2013-11-27 6:19 ` [PATCH 10/17] tracing/probes: Move 'symbol' fetch method to kprobes Namhyung Kim
2013-11-27 6:19 ` [PATCH 11/17] tracing/probes: Add fetch{,_size} member into deref fetch method Namhyung Kim
2013-11-27 6:19 ` [PATCH 12/17] tracing/probes: Implement 'memory' fetch method for uprobes Namhyung Kim
2013-11-27 6:19 ` [PATCH 13/17] tracing/uprobes: Pass 'is_return' to traceprobe_parse_probe_arg() Namhyung Kim
2013-11-27 6:20 ` [PATCH 14/17] tracing/uprobes: Fetch args before reserving a ring buffer Namhyung Kim
2013-11-27 6:20 ` [PATCH 15/17] tracing/uprobes: Add support for full argument access methods Namhyung Kim
2013-11-27 6:20 ` [PATCH 16/17] uprobes: Allocate ->utask before handler_chain() for tracing handlers Namhyung Kim
2013-11-27 6:20 ` [PATCH/RFC 17/17] tracing/uprobes: Add @+file_offset fetch method Namhyung Kim
2013-11-27 18:55 ` Oleg Nesterov
2013-11-28 7:56 ` Namhyung Kim
2013-11-28 16:31 ` Oleg Nesterov
2013-11-29 0:25 ` Namhyung Kim
2013-11-29 16:51 ` Oleg Nesterov
2013-12-03 6:23 ` Namhyung Kim
2013-12-03 9:32 ` Masami Hiramatsu
2013-11-27 11:51 ` [PATCHSET 00/17] tracing/uprobes: Add support for more fetch methods (v7) Masami Hiramatsu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5296C389.7060600@hitachi.com \
--to=masami.hiramatsu.pt@hitachi.com \
--cc=acme@ghostprotocols.net \
--cc=cheol.lee@lge.com \
--cc=hkshaw@linux.vnet.ibm.com \
--cc=jovi.zhangwei@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=namhyung.kim@lge.com \
--cc=namhyung@kernel.org \
--cc=oleg@redhat.com \
--cc=rostedt@goodmis.org \
--cc=srikar@linux.vnet.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome