From: HATAYAMA Daisuke <d.hatayama@jp.fujitsu.com>
To: David Rientjes <rientjes@google.com>
Cc: "H. Peter Anvin" <hpa@zytor.com>, Ingo Molnar <mingo@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
"x86@kernel.org" <x86@kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Vivek Goyal <vgoyal@redhat.com>
Subject: Re: [PATCH] x86, apic: clean up handling of boot_cpu_physical_apicid in boot process
Date: Mon, 27 Jan 2014 11:55:09 +0900 [thread overview]
Message-ID: <52E5CA8D.7000602@jp.fujitsu.com> (raw)
In-Reply-To: <alpine.DEB.2.02.1401252000050.10325@chino.kir.corp.google.com>
(2014/01/26 13:02), David Rientjes wrote:
> On Thu, 16 Jan 2014, HATAYAMA Daisuke wrote:
>
>> Hello,
>>
>> This patch deals with the issue of handling boot_cpu_physical_apicid
>> in boot process I avoided in disable_cpu_apicid patch because I
>> cannot guess how long it needs to take for the review of this fix.
>>
>> This patch is made on top of today's x86/apic branch of tip tree.
>> Its commit hash is 5b4d1dbc24bb6fd7179ada0f47be34e27e64decb
>>
>
> This breaks with SGI 320/540:
>
> arch/x86/platform/visws/visws_quirks.c: In function ‘MP_processor_info’:
> arch/x86/platform/visws/visws_quirks.c:169:3: error: ‘bios_cpu_physical_apicid’ undeclared (first use in this function)
> arch/x86/platform/visws/visws_quirks.c:169:3: note: each undeclared identifier is reported only once for each function it appears in
>
Thanks. I'll retry with CONFIG_X86_VISWS...
obj-$(CONFIG_X86_VISWS) += visws_quirks.o
> It makes it pretty apparent that you want a different name for the new
> variable, bios_bsp_physical_apicid is just too close to
> boot_cpu_physical_apicid that even the author of the patch missed a
> conversion.
>
``bsp'' and ``boot cpu'' are different, but certainly they are close
for most of people who don't need to focus the difference.
One idea is not to add bios_bsp_physical_apicid, just removing
assignment to boot_cpu_physical_apicid from MP_processor_info().
I guess currently no one uses apicid provided by MP table
since boot_cpu_physical_apicid is finally initialized in
init_apic_mappings().
> (It's also really sad that we can't make it __initdata since it's only
> valid at boot because of the hotplug stuff.)
>
--
Thanks.
HATAYAMA, Daisuke
next prev parent reply other threads:[~2014-01-27 2:56 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-16 9:40 HATAYAMA Daisuke
2014-01-26 4:02 ` David Rientjes
2014-01-27 2:55 ` HATAYAMA Daisuke [this message]
2014-01-27 23:58 ` David Rientjes
2014-02-05 16:38 ` Vivek Goyal
2014-02-05 17:09 ` Vivek Goyal
2014-02-05 16:40 ` Vivek Goyal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=52E5CA8D.7000602@jp.fujitsu.com \
--to=d.hatayama@jp.fujitsu.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=rientjes@google.com \
--cc=tglx@linutronix.de \
--cc=vgoyal@redhat.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome