From: Roland Dreier <roland@topspin.com>
To: Bjorn Helgaas <bjorn.helgaas@hp.com>
Cc: Andrew Morton <akpm@osdl.org>,
linux-kernel@vger.kernel.org,
Tom L Nguyen <tom.l.nguyen@intel.com>
Subject: Re: [PATCH] rename CONFIG_PCI_USE_VECTOR to CONFIG_PCI_MSI
Date: Mon, 26 Jul 2004 15:39:23 -0700 [thread overview]
Message-ID: <52llh65r6s.fsf@topspin.com> (raw)
In-Reply-To: <200407261615.52261.bjorn.helgaas@hp.com> (Bjorn Helgaas's message of "Mon, 26 Jul 2004 16:15:52 -0600")
Bjorn> Rename CONFIG_PCI_USE_VECTOR to CONFIG_PCI_MSI. The
Bjorn> "vector" terminology is architecture-dependent. The PCI
Bjorn> MSI interface actually deals with Linux IRQ numbers (i.e.,
Bjorn> things you can pass to request_irq()), and we shouldn't
Bjorn> confuse things by calling them "vectors" just because we're
Bjorn> using MSI rather than an IOSAPIC.
Seems reasonable... however CONFIG_PCI_USE_VECTOR really has two
overloaded meanings (at least on i386). First of all, as you say, it
does enable drivers to request MSI/MSI-X. However, on i386
CONFIG_PCI_USE_VECTOR also changes how the APIC is setup (the most
visible effect of which is different interrupt numbers).
I would propose the following course of action:
1) Merge Long's latest MSI/MSI-X patches (updated patches in
http://gmane.linux.kernel/218830). Without the new semantics of
pci_disable_msi()/pci_disable_msix(), it's very difficult to use
MSI/MSI-X in a device driver.
2) Split the config options so we have an i386-specific
CONFIG_PCI_USE_VECTOR and a generic CONFIG_PCI_MSI (with
CONFIG_PCI_MSI depending on something like !I386 || CONFIG_PCI_USE_VECTOR)
This would be an updated version of your patch.
3) Make the code in drivers/pci/msi.c less Intel-specific -- instead
of hard-coding Intel-specific addresses for vectors have the
computation call into arch code. This would be a fair amount of
work and depends documentation for non-Intel platforms that
implement MSI/MSI-X -- should be easier as PCI Express comes out.
- Roland
next prev parent reply other threads:[~2004-07-26 22:39 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-07-26 22:15 Bjorn Helgaas
2004-07-26 22:39 ` Roland Dreier [this message]
2004-07-26 22:45 ` Roland Dreier
2004-07-26 23:34 ` Bjorn Helgaas
2004-07-27 1:03 ` Roland Dreier
2004-07-27 5:48 ` Zwane Mwaikambo
[not found] ` <20040726164324.683ff471.akpm@osdl.org>
[not found] ` <524qnu5j8l.fsf@topspin.com>
[not found] ` <20040726183917.65927925.akpm@osdl.org>
[not found] ` <20040727023927.GB24599@kroah.com>
2004-07-28 17:08 ` [PATCH][1/2] Stop using dev->bus->ops directly in msi.c Roland Dreier
2004-07-28 17:11 ` [PATCH][2/2] MSI/MSI-X API updates Roland Dreier
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=52llh65r6s.fsf@topspin.com \
--to=roland@topspin.com \
--cc=akpm@osdl.org \
--cc=bjorn.helgaas@hp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=tom.l.nguyen@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®