From: Subhajit Ghosh <subhajit.ghosh@tweaklogic.com>
To: SAJJA EASWAR SAI <eshwarsajja20@gmail.com>, jic23@kernel.org
Cc: dlechner@baylibre.com, nuno.sa@analog.com, andy@kernel.org,
linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org,
iryuken@duck.com
Subject: Re: [PATCH] iio: light: apds9306: remove redundant explicit pointer cast
Date: Fri, 30 Jan 2026 09:14:41 +1030 [thread overview]
Message-ID: <531a0877-53a3-46b0-b365-93e0511bbe2e@tweaklogic.com> (raw)
In-Reply-To: <20260129210431.654266-1-eshwarsajja20@gmail.com>
On 30/1/26 07:34, SAJJA EASWAR SAI wrote:
> C allows implicit conversion from void * to struct apds9306_data *, so the
> explicit cast on 'ptr' is unnecessary. Removing it improves readability.
>
> Signed-off-by: SAJJA EASWAR SAI <eshwarsajja20@gmail.com>
> ---
> drivers/iio/light/apds9306.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/iio/light/apds9306.c b/drivers/iio/light/apds9306.c
> index 7e68cca0e..5d18eabd9 100644
> --- a/drivers/iio/light/apds9306.c
> +++ b/drivers/iio/light/apds9306.c
> @@ -1176,7 +1176,7 @@ static int apds9306_init_iio_gts(struct apds9306_data *data)
>
> static void apds9306_powerdown(void *ptr)
> {
> - struct apds9306_data *data = (struct apds9306_data *)ptr;
> + struct apds9306_data *data = ptr;
> struct apds9306_regfields *rf = &data->rf;
> int ret;
>
Looks good. Thank you.
Acked-by: Subhajit Ghosh <subhajit.ghosh@tweaklogic.com>
Regards,
Subhajit Ghosh
next prev parent reply other threads:[~2026-01-29 22:43 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-29 21:04 SAJJA EASWAR SAI
2026-01-29 22:44 ` Subhajit Ghosh [this message]
2026-01-31 17:18 ` Jonathan Cameron
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=531a0877-53a3-46b0-b365-93e0511bbe2e@tweaklogic.com \
--to=subhajit.ghosh@tweaklogic.com \
--cc=andy@kernel.org \
--cc=dlechner@baylibre.com \
--cc=eshwarsajja20@gmail.com \
--cc=iryuken@duck.com \
--cc=jic23@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nuno.sa@analog.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®