mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Chanwoo Choi <cw00.choi@samsung.com>
To: Greg KH <gregkh@linuxfoundation.org>
Cc: MyungJoo Ham <myungjoo.ham@samsung.com>,
	Kyungmin Park <kyungmin.park@samsung.com>,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: [GIT PULL] extcon next for 3.15
Date: Wed, 19 Mar 2014 16:53:13 +0900	[thread overview]
Message-ID: <53294CE9.8030301@samsung.com> (raw)

Dear Greg,

This is extcon-next full request for v3.15. I add detailed description of this
pull request on below. Please pull extcon with following updates.

This patchset is rebased on 'Linux 3-14-rc5' because char-misc-next is based on
'Linux 3-14-rc5'.

Best Regards,
Chanwoo Choi

The following changes since commit 0414855fdc4a40da05221fc6062cccbc0c30f169:

  Linux 3.14-rc5 (2014-03-02 18:56:16 -0800)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-3.15

for you to fetch changes up to 1ad94ffef22c0a6e2ee6ba90a800c32fd29ffa1f:

  extcon: Move OF helper function to extcon core and change function name (2014-03-19 14:41:58 +0900)

----------------------------------------------------------------
Update extcon for v3.15

This patchset fix minor issue.

The extcon-palmas/gpio use SIMPLE_DEV_PM_OPS macro instead of legacy method.
OF helper function of extcon move in extcon core to remove separate of_extcon.c
and change the name of OF helper function as following because previous function
name is complicated and ambiguous naming.
- of_extcon_get_extcon_dev() -> extcon_get_edev_by_phandle()

----------------------------------------------------------------
Chanwoo Choi (2):
      extcon: of: Remove unnecessary function call by using the name of device_node
      extcon: Move OF helper function to extcon core and change function name

Jingoo Han (2):
      extcon: palmas: Use SIMPLE_DEV_PM_OPS macro
      extcon: gpio: Use SIMPLE_DEV_PM_OPS macro

 drivers/extcon/Kconfig           |  4 ---
 drivers/extcon/Makefile          |  2 --
 drivers/extcon/extcon-class.c    | 42 ++++++++++++++++++++++++++
 drivers/extcon/extcon-gpio.c     |  4 +--
 drivers/extcon/extcon-palmas.c   |  5 +---
 drivers/extcon/of_extcon.c       | 64 ----------------------------------------
 drivers/usb/dwc3/dwc3-omap.c     |  3 +-
 include/linux/extcon.h           | 12 ++++++++
 include/linux/extcon/of_extcon.h | 31 -------------------
 9 files changed, 57 insertions(+), 110 deletions(-)
 delete mode 100644 drivers/extcon/of_extcon.c
 delete mode 100644 include/linux/extcon/of_extcon.h

             reply	other threads:[~2014-03-19  7:53 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-03-19  7:53 Chanwoo Choi [this message]
2014-03-19 17:06 ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=53294CE9.8030301@samsung.com \
    --to=cw00.choi@samsung.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kyungmin.park@samsung.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=myungjoo.ham@samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome