mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Hildenbrand <david@redhat.com>
To: Ryan Roberts <ryan.roberts@arm.com>, linux-kernel@vger.kernel.org
Cc: linux-mm@kvack.org, Andrew Morton <akpm@linux-foundation.org>,
	"Matthew Wilcox (Oracle)" <willy@infradead.org>,
	Hugh Dickins <hughd@google.com>,
	Yin Fengwei <fengwei.yin@intel.com>,
	Mike Kravetz <mike.kravetz@oracle.com>,
	Muchun Song <muchun.song@linux.dev>, Peter Xu <peterx@redhat.com>
Subject: Re: [PATCH RFC 00/39] mm/rmap: interface overhaul
Date: Tue, 5 Dec 2023 14:39:39 +0100	[thread overview]
Message-ID: <537ac106-e4f6-4845-aa09-29b775269562@redhat.com> (raw)
In-Reply-To: <1ba5dd86-a201-4243-bab0-349395468236@arm.com>

On 05.12.23 14:31, Ryan Roberts wrote:
> On 05/12/2023 09:56, David Hildenbrand wrote:
>>>>
>>>> Ryan has series where we would make use of folio_remove_rmap_ptes() [1]
>>>> -- he carries his own batching variant right now -- and
>>>> folio_try_dup_anon_rmap_ptes()/folio_dup_file_rmap_ptes() [2].
>>>
>>> Note that the contpte series at [2] has a new patch in v3 (patch 2), which could
>>> benefit from folio_remove_rmap_ptes() or equivalent. My plan was to revive [1]
>>> on top of [2] once it is merged.
>>>
>>>>
>>>> There is some overlap with both series (and some other work, like
>>>> multi-size THP [3]), so that will need some coordination, and likely a
>>>> stepwise inclusion.
>>>
>>> Selfishly, I'd really like to get my stuff merged as soon as there is no
>>> technical reason not to. I'd prefer not to add this as a dependency if we can
>>> help it.
>>
>> It's easy to rework either series on top of each other. The mTHP series has
>> highest priority,
>> no question, that will go in first.
> 
> Music to my ears! It would be great to either get a reviewed-by or feedback on
> why not, for the key 2 patches in that series (3 & 4) and also your opinion on
> whether we need to wait for compaction to land (see cover letter). It would be
> great to get this into linux-next ASAP IMHO.

On it :)

> 
>>
>> Regarding the contpte, I think it needs more work. Especially, as raised, to not
>> degrade
>> order-0 performance. Maybe we won't make the next merge window (and you already
>> predicated
>> that in some cover letter :P ). Let's see.
> 
> Yeah that's ok. I'll do the work to fix the order-0 perf. And also do the same
> for patch 2 in that series - would also be really helpful if you had a chance to
> look at patch 2 - its new for v3.

I only skimmed over it, but it seems to go into the direction we'll 
need. Keeping order-0 performance unharmed should have highest priority. 
Hopefully my microbenchmarks are helpful.

> 
>>
>> But again, the conflicts are all trivial, so I'll happily rebase on top of
>> whatever is
>> in mm-unstable. Or move the relevant rework to the front so you can just carry
>> them/base on them. (the batched variants for dup do make the contpte code much
>> easier)
> 
> So perhaps we should aim for mTHP, then this, then contpte last, benefiting from
> the batching.

Yeah. And again, I don't care too much if I have to rebase on top of 
your work if this here takes longer. It's all a fairly trivial conversion.

>>
>> [...]
>>
>>>>
>>>>
>>>> New (extended) hugetlb interface that operate on entire folio:
>>>>    * hugetlb_add_new_anon_rmap() -> Already existed
>>>>    * hugetlb_add_anon_rmap() -> Already existed
>>>>    * hugetlb_try_dup_anon_rmap()
>>>>    * hugetlb_try_share_anon_rmap()
>>>>    * hugetlb_add_file_rmap()
>>>>    * hugetlb_remove_rmap()
>>>>
>>>> New "ordinary" interface for small folios / THP::
>>>>    * folio_add_new_anon_rmap() -> Already existed
>>>>    * folio_add_anon_rmap_[pte|ptes|pmd]()
>>>>    * folio_try_dup_anon_rmap_[pte|ptes|pmd]()
>>>>    * folio_try_share_anon_rmap_[pte|pmd]()
>>>>    * folio_add_file_rmap_[pte|ptes|pmd]()
>>>>    * folio_dup_file_rmap_[pte|ptes|pmd]()
>>>>    * folio_remove_rmap_[pte|ptes|pmd]()
>>>
>>> I'm not sure if there are official guidelines, but personally if we are
>>> reworking the API, I'd take the opportunity to move "rmap" to the front of the
>>> name, rather than having it burried in the middle as it is for some of these:
>>>
>>> rmap_hugetlb_*()
>>>
>>> rmap_folio_*()
>>
>> No strong opinion. But we might want slightly different names then. For example,
>> it's "bio_add_folio" and not "bio_folio_add":
>>
>>
>> rmap_add_new_anon_hugetlb()
>> rmap_add_anon_hugetlb()
>> ...
>> rmap_remove_hugetlb()
>>
>>
>> rmap_add_new_anon_folio()
>> rmap_add_anon_folio_[pte|ptes|pmd]()
>> ...
>> rmap_dup_file_folio_[pte|ptes|pmd]()
>> rmap_remove_folio_[pte|ptes|pmd]()
>>
>> Thoughts?
> 
> Having now reviewed your series, I have a less strong opinion, perhaps it's
> actually best with your original names; "folio" is actually the subject after
> all; it's the thing being operated on.
> 

I think having "folio" in there looks cleaner and more consistent to 
other functions.

I tend to like "rmap_dup_file_folio_[pte|ptes|pmd]()", because then we 
have "file folio" and "anon folio" as one word.

But then I wonder about the hugetlb part. Maybe simply 
"hugetlb_rmap_remove_folio()" etc.

Having the "hugetlb_" prefix at the beginning feels like the right thing 
to do, looking at orher hugetlb special-handlings.

But I'll wait a bit until I go crazy on renaming :)

> 
>>
>>>
>>> I guess reading the patches will tell me, but what's the point of "ptes"? Surely
>>> you're either mapping at pte or pmd level, and the number of pages is determined
>>> by the folio size? (or presumably nr param passed in)
>>
>> It's really (currently) one function to handle 1 vs. multiple PTEs. For example:
>>
>> void folio_remove_rmap_ptes(struct folio *, struct page *, unsigned int nr,
>>          struct vm_area_struct *);
>> #define folio_remove_rmap_pte(folio, page, vma) \
>>      folio_remove_rmap_ptes(folio, page, 1, vma)
>> void folio_remove_rmap_pmd(struct folio *, struct page *,
>>          struct vm_area_struct *);
> 
> Yeah now that I've looked at the series, this makes sense. "ptes" was originally
> making me think of contpte, but I suspect I'll be the only one with that
> association :)

Ah, yes :)

-- 
Cheers,

David / dhildenb


  reply	other threads:[~2023-12-05 13:39 UTC|newest]

Thread overview: 82+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-04 14:21 David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 01/39] mm/rmap: rename hugepage_add* to hugetlb_add* David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 02/39] mm/rmap: introduce and use hugetlb_remove_rmap() David Hildenbrand
2023-12-06  1:22   ` Yin Fengwei
2023-12-06 12:11     ` David Hildenbrand
2023-12-07  0:56       ` Yin Fengwei
2023-12-04 14:21 ` [PATCH RFC 03/39] mm/rmap: introduce and use hugetlb_add_file_rmap() David Hildenbrand
2023-12-06  1:22   ` Yin Fengwei
2023-12-04 14:21 ` [PATCH RFC 04/39] mm/rmap: introduce and use hugetlb_try_dup_anon_rmap() David Hildenbrand
2023-12-06  1:22   ` Yin Fengwei
2023-12-04 14:21 ` [PATCH RFC 05/39] mm/rmap: introduce and use hugetlb_try_share_anon_rmap() David Hildenbrand
2023-12-06  1:23   ` Yin Fengwei
2023-12-04 14:21 ` [PATCH RFC 06/39] mm/rmap: add hugetlb sanity checks David Hildenbrand
2023-12-06  1:23   ` Yin Fengwei
2023-12-04 14:21 ` [PATCH RFC 07/39] mm/rmap: convert folio_add_file_rmap_range() into folio_add_file_rmap_[pte|ptes|pmd]() David Hildenbrand
2023-12-05 12:04   ` Ryan Roberts
2023-12-05 12:25     ` David Hildenbrand
2023-12-06  1:30   ` Yin Fengwei
2023-12-06  9:17     ` David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 08/39] mm/memory: page_add_file_rmap() -> folio_add_file_rmap_[pte|pmd]() David Hildenbrand
2023-12-08  1:40   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 09/39] mm/huge_memory: page_add_file_rmap() -> folio_add_file_rmap_pmd() David Hildenbrand
2023-12-08  1:41   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 10/39] mm/migrate: page_add_file_rmap() -> folio_add_file_rmap_pte() David Hildenbrand
2023-12-08  1:42   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 11/39] mm/userfaultfd: " David Hildenbrand
2023-12-08  1:42   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 12/39] mm/rmap: remove page_add_file_rmap() David Hildenbrand
2023-12-08  1:42   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 13/39] mm/rmap: factor out adding folio mappings into __folio_add_rmap() David Hildenbrand
2023-12-08  1:44   ` Yin, Fengwei
2023-12-04 14:21 ` [PATCH RFC 14/39] mm/rmap: introduce folio_add_anon_rmap_[pte|ptes|pmd]() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 15/39] mm/huge_memory: batch rmap operations in __split_huge_pmd_locked() David Hildenbrand
2023-12-05 12:22   ` Ryan Roberts
2023-12-05 12:26     ` David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 16/39] mm/huge_memory: page_add_anon_rmap() -> folio_add_anon_rmap_pmd() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 17/39] mm/migrate: page_add_anon_rmap() -> folio_add_anon_rmap_pte() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 18/39] mm/ksm: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 19/39] mm/swapfile: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 20/39] mm/memory: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 21/39] mm/rmap: remove page_add_anon_rmap() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 22/39] mm/rmap: remove RMAP_COMPOUND David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 23/39] mm/rmap: introduce folio_remove_rmap_[pte|ptes|pmd]() David Hildenbrand
2023-12-05 12:52   ` Ryan Roberts
2023-12-05 13:09     ` David Hildenbrand
2023-12-05 13:37       ` Ryan Roberts
2023-12-04 14:21 ` [PATCH RFC 24/39] kernel/events/uprobes: page_remove_rmap() -> folio_remove_rmap_pte() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 25/39] mm/huge_memory: page_remove_rmap() -> folio_remove_rmap_pmd() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 26/39] mm/khugepaged: page_remove_rmap() -> folio_remove_rmap_pte() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 27/39] mm/ksm: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 28/39] mm/memory: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 29/39] mm/migrate_device: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 30/39] mm/rmap: " David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 31/39] Documentation: stop referring to page_remove_rmap() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 32/39] mm/rmap: remove page_remove_rmap() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 33/39] mm/rmap: convert page_dup_file_rmap() to folio_dup_file_rmap_[pte|ptes|pmd]() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 34/39] mm/rmap: introduce folio_try_dup_anon_rmap_[pte|ptes|pmd]() David Hildenbrand
2023-12-04 17:59   ` David Hildenbrand
2023-12-05 13:11   ` David Hildenbrand
2023-12-05 13:12   ` Ryan Roberts
2023-12-05 13:17     ` David Hildenbrand
2023-12-05 13:18       ` David Hildenbrand
2023-12-05 13:40         ` Ryan Roberts
2023-12-05 13:50           ` David Hildenbrand
2023-12-05 14:02             ` Ryan Roberts
2023-12-05 14:12               ` David Hildenbrand
2023-12-05 13:32       ` David Hildenbrand
2023-12-05 13:40         ` Ryan Roberts
2023-12-04 14:21 ` [PATCH RFC 35/39] mm/huge_memory: page_try_dup_anon_rmap() -> folio_try_dup_anon_rmap_pmd() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 36/39] mm/memory: page_try_dup_anon_rmap() -> folio_try_dup_anon_rmap_pte() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 37/39] mm/rmap: remove page_try_dup_anon_rmap() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 38/39] mm: convert page_try_share_anon_rmap() to folio_try_share_anon_rmap_[pte|pmd]() David Hildenbrand
2023-12-04 14:21 ` [PATCH RFC 39/39] mm/rmap: rename COMPOUND_MAPPED to ENTIRELY_MAPPED David Hildenbrand
2023-12-04 19:53 ` [PATCH RFC 00/39] mm/rmap: interface overhaul Ryan Roberts
2023-12-05  9:56   ` David Hildenbrand
2023-12-05 13:31     ` Ryan Roberts
2023-12-05 13:39       ` David Hildenbrand [this message]
2023-12-05 13:49         ` Ryan Roberts
2023-12-05 13:55           ` David Hildenbrand
2023-12-08 11:24           ` David Hildenbrand
2023-12-08 11:38             ` Ryan Roberts
2023-12-05 12:29   ` Ryan Roberts

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=537ac106-e4f6-4845-aa09-29b775269562@redhat.com \
    --to=david@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=fengwei.yin@intel.com \
    --cc=hughd@google.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mike.kravetz@oracle.com \
    --cc=muchun.song@linux.dev \
    --cc=peterx@redhat.com \
    --cc=ryan.roberts@arm.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®